summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-03-17 11:45:39 -0400
committerMike Gilbert <floppym@gentoo.org>2024-03-17 12:34:05 -0400
commit7b06ba9d0e31f7218cc5c0f3e712c437caacc298 (patch)
tree439734742f594a07a6542728cb1b74da98c2a9c4 /net-misc/freerdp
parentnet-misc/freerdp: add option helper (diff)
downloadgentoo-7b06ba9d0e31f7218cc5c0f3e712c437caacc298.tar.gz
gentoo-7b06ba9d0e31f7218cc5c0f3e712c437caacc298.tar.bz2
gentoo-7b06ba9d0e31f7218cc5c0f3e712c437caacc298.zip
net-misc/freerdp: enable wayland only with client
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-misc/freerdp')
-rw-r--r--net-misc/freerdp/freerdp-2.11.5-r10.ebuild18
-rw-r--r--net-misc/freerdp/freerdp-2.9999.ebuild18
-rw-r--r--net-misc/freerdp/freerdp-3.4.0-r10.ebuild18
-rw-r--r--net-misc/freerdp/freerdp-9999.ebuild18
4 files changed, 56 insertions, 16 deletions
diff --git a/net-misc/freerdp/freerdp-2.11.5-r10.ebuild b/net-misc/freerdp/freerdp-2.11.5-r10.ebuild
index febcc0e3d5c5..e3c30486ef78 100644
--- a/net-misc/freerdp/freerdp-2.11.5-r10.ebuild
+++ b/net-misc/freerdp/freerdp-2.11.5-r10.ebuild
@@ -80,9 +80,11 @@ COMMON_DEPEND="
)
smartcard? ( sys-apps/pcsc-lite )
systemd? ( sys-apps/systemd:0= )
- wayland? (
- dev-libs/wayland
- x11-libs/libxkbcommon
+ client? (
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
)
X? (
x11-libs/libX11
@@ -108,6 +110,14 @@ option() {
usex "$1" ON OFF
}
+option_client() {
+ if use client; then
+ option "$1"
+ else
+ echo OFF
+ fi
+}
+
src_configure() {
# bug #881695
filter-lto
@@ -141,7 +151,7 @@ src_configure() {
-DWITH_X11=$(option X)
-DWITH_XINERAMA=$(option xinerama)
-DWITH_XV=$(option xv)
- -DWITH_WAYLAND=$(option wayland)
+ -DWITH_WAYLAND=$(option_client wayland)
-DWITH_WINPR_TOOLS=$(option tools)
)
cmake_src_configure
diff --git a/net-misc/freerdp/freerdp-2.9999.ebuild b/net-misc/freerdp/freerdp-2.9999.ebuild
index 018ae103d0e0..035df26f5b1e 100644
--- a/net-misc/freerdp/freerdp-2.9999.ebuild
+++ b/net-misc/freerdp/freerdp-2.9999.ebuild
@@ -80,9 +80,11 @@ COMMON_DEPEND="
)
smartcard? ( sys-apps/pcsc-lite )
systemd? ( sys-apps/systemd:0= )
- wayland? (
- dev-libs/wayland
- x11-libs/libxkbcommon
+ client? (
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
)
X? (
x11-libs/libX11
@@ -103,6 +105,14 @@ option() {
usex "$1" ON OFF
}
+option_client() {
+ if use client; then
+ option "$1"
+ else
+ echo OFF
+ fi
+}
+
src_configure() {
# bug #881695
filter-lto
@@ -136,7 +146,7 @@ src_configure() {
-DWITH_X11=$(option X)
-DWITH_XINERAMA=$(option xinerama)
-DWITH_XV=$(option xv)
- -DWITH_WAYLAND=$(option wayland)
+ -DWITH_WAYLAND=$(option_client wayland)
-DWITH_WINPR_TOOLS=$(option tools)
)
cmake_src_configure
diff --git a/net-misc/freerdp/freerdp-3.4.0-r10.ebuild b/net-misc/freerdp/freerdp-3.4.0-r10.ebuild
index 93c7a794de74..1821299544d6 100644
--- a/net-misc/freerdp/freerdp-3.4.0-r10.ebuild
+++ b/net-misc/freerdp/freerdp-3.4.0-r10.ebuild
@@ -86,9 +86,11 @@ COMMON_DEPEND="
sys-apps/pcsc-lite
)
systemd? ( sys-apps/systemd:0= )
- wayland? (
- dev-libs/wayland
- x11-libs/libxkbcommon
+ client? (
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
)
X? (
x11-libs/libX11
@@ -109,6 +111,14 @@ option() {
usex "$1" ON OFF
}
+option_client() {
+ if use client; then
+ option "$1"
+ else
+ echo OFF
+ fi
+}
+
src_configure() {
# bug #881695
filter-lto
@@ -152,7 +162,7 @@ src_configure() {
-DWITH_X11=$(option X)
-DWITH_XINERAMA=$(option xinerama)
-DWITH_XV=$(option xv)
- -DWITH_WAYLAND=$(option wayland)
+ -DWITH_WAYLAND=$(option_client wayland)
-DWITH_WEBVIEW=OFF
-DWITH_WINPR_TOOLS=$(option tools)
)
diff --git a/net-misc/freerdp/freerdp-9999.ebuild b/net-misc/freerdp/freerdp-9999.ebuild
index 93c7a794de74..1821299544d6 100644
--- a/net-misc/freerdp/freerdp-9999.ebuild
+++ b/net-misc/freerdp/freerdp-9999.ebuild
@@ -86,9 +86,11 @@ COMMON_DEPEND="
sys-apps/pcsc-lite
)
systemd? ( sys-apps/systemd:0= )
- wayland? (
- dev-libs/wayland
- x11-libs/libxkbcommon
+ client? (
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
)
X? (
x11-libs/libX11
@@ -109,6 +111,14 @@ option() {
usex "$1" ON OFF
}
+option_client() {
+ if use client; then
+ option "$1"
+ else
+ echo OFF
+ fi
+}
+
src_configure() {
# bug #881695
filter-lto
@@ -152,7 +162,7 @@ src_configure() {
-DWITH_X11=$(option X)
-DWITH_XINERAMA=$(option xinerama)
-DWITH_XV=$(option xv)
- -DWITH_WAYLAND=$(option wayland)
+ -DWITH_WAYLAND=$(option_client wayland)
-DWITH_WEBVIEW=OFF
-DWITH_WINPR_TOOLS=$(option tools)
)