summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/bgpq3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/bgpq3')
-rw-r--r--net-misc/bgpq3/Manifest2
-rw-r--r--net-misc/bgpq3/bgpq3-0.1.21.ebuild32
-rw-r--r--net-misc/bgpq3/bgpq3-0.1.22.ebuild32
-rw-r--r--net-misc/bgpq3/metadata.xml25
4 files changed, 91 insertions, 0 deletions
diff --git a/net-misc/bgpq3/Manifest b/net-misc/bgpq3/Manifest
new file mode 100644
index 000000000000..69c5e3ec6721
--- /dev/null
+++ b/net-misc/bgpq3/Manifest
@@ -0,0 +1,2 @@
+DIST bgpq3-0.1.21.tgz 62181 SHA256 ba3a4b9703984ad17c3a5aa4fb69248323372de2dfd1680b37fa066d2f6eb9ec SHA512 173bf0267c0010d90fd652e89cd9c389bddbb4019a706bf7f53dd1d2b3dd1b2fb7b88b92abd3b0ba7fe784539c023f9a33f26551a17a53a29a523e0ad3a6ccc3 WHIRLPOOL 90fe382bcfb749ed5f6ece37ac9f125fa94509a39d062104875767f7f73f4fa75265dfc77ef1e895478d70f0b32ab3556357cc29ea05c976e6b1568083e3cdcb
+DIST bgpq3-0.1.22.tgz 62550 SHA256 ce1aa4321573565f5b87966725fa198b238c4c4b13ea855ff6d80071f6b77814 SHA512 c2d0d1f209bdd1016a0c5d3e048b3700c1725b6c4135ba8d47daf3ef03fc05f31a190b640d143f3b6ac8b529754539285673caaf3dbf9cc11d80df1b8920f79c WHIRLPOOL 4a77bb35332eedb0371c4bcd858c6189ae8c4fe95f515c49df19ab6c8edecc9f080a94f9c349b62799d05dfe2e7c2acd244f4bab8eb28bc4ccee11337dc54aeb
diff --git a/net-misc/bgpq3/bgpq3-0.1.21.ebuild b/net-misc/bgpq3/bgpq3-0.1.21.ebuild
new file mode 100644
index 000000000000..1fe2a78537bd
--- /dev/null
+++ b/net-misc/bgpq3/bgpq3-0.1.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Generate access-lists for Cisco/Juniper routers, successor of bgpq"
+HOMEPAGE="http://snar.spb.ru/prog/bgpq3/"
+SRC_URI="http://snar.spb.ru/prog/bgpq3/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ # Respect CFLAGS and LDFLAGS
+ sed -i \
+ -e '/^CFLAGS=/s/-g //' \
+ -e '/^CFLAGS=/s/ -O0//' \
+ Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_install() {
+ dobin bgpq3
+ doman bgpq3.8
+ dodoc CHANGES
+ dohtml *.html
+}
diff --git a/net-misc/bgpq3/bgpq3-0.1.22.ebuild b/net-misc/bgpq3/bgpq3-0.1.22.ebuild
new file mode 100644
index 000000000000..4673d9a4b30e
--- /dev/null
+++ b/net-misc/bgpq3/bgpq3-0.1.22.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Generate access-lists for Cisco/Juniper routers, successor of bgpq"
+HOMEPAGE="http://snar.spb.ru/prog/bgpq3/"
+SRC_URI="http://snar.spb.ru/prog/bgpq3/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ # Respect CFLAGS
+ sed -i \
+ -e '/^CFLAGS=/s/-g //' \
+ -e '/^CFLAGS=/s/ -O0//' \
+ Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_install() {
+ dobin bgpq3
+ doman bgpq3.8
+ dodoc CHANGES
+ dohtml *.html
+}
diff --git a/net-misc/bgpq3/metadata.xml b/net-misc/bgpq3/metadata.xml
new file mode 100644
index 000000000000..1e87335024ff
--- /dev/null
+++ b/net-misc/bgpq3/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <longdescription lang="en">
+ bgpq3 allows to generate different config entries with prefix lists, useful for Cisco/Juniper routers and their software analogs, such as Quagga.
+ This program is a successor of bgpq from same author, main difference - it supports IPv6.
+ </longdescription>
+ <longdescription lang="ru">
+ bgpq3 позволяет создавать различные чaсти конфигурационных файлов со списком сетей для маршрутизаторов Cisco/Juniper и их программных аналогов,
+ таких как Quagga.
+ Данная программа - идейный наследник bgpq от того же автора, основное отличие - поддержка IPv6.
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>snar@snar.spb.ru</email>
+ <name>Alexandre Snarskii</name>
+ </maintainer>
+ <remote-id type="github">snar/bgpq3</remote-id>
+ <bugs-to>https://github.com/snar/bgpq3/issues</bugs-to>
+ </upstream>
+</pkgmetadata>