summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-16 20:37:14 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-16 20:37:30 +0300
commit6de8c28ee16da4ca2540fe416fab04a70c95e91b (patch)
treee955bfa6ffec4aa6084e53fbda9289eb53119bfc /net-mail/isync
parentsys-fs/zfs-kmod: 0.8.5: Marked compatiable with 5.9 kernels. (diff)
downloadgentoo-6de8c28ee16da4ca2540fe416fab04a70c95e91b.tar.gz
gentoo-6de8c28ee16da4ca2540fe416fab04a70c95e91b.tar.bz2
gentoo-6de8c28ee16da4ca2540fe416fab04a70c95e91b.zip
net-mail/isync: Version bump
Closes: https://bugs.gentoo.org/739254 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'net-mail/isync')
-rw-r--r--net-mail/isync/Manifest1
-rw-r--r--net-mail/isync/isync-1.3.3.ebuild45
-rw-r--r--net-mail/isync/isync-9999.ebuild7
3 files changed, 50 insertions, 3 deletions
diff --git a/net-mail/isync/Manifest b/net-mail/isync/Manifest
index e0a7e7801699..3b311cdee7e3 100644
--- a/net-mail/isync/Manifest
+++ b/net-mail/isync/Manifest
@@ -1 +1,2 @@
DIST isync-1.3.1.tar.gz 311868 BLAKE2B e7eae36407873b8f9f3c4e9a827e719aefa608994f5a48a93779207148123c7b796f6aa8ad8157f5eb9e863c5845889ad595d23570f12a0520fe997f8282158c SHA512 59d702d41d4a4e72f03cb282b414d0bb859593171763e845bc24d116a74f807a79e5be61f1dd1f59a9ece492322bceac156b08958a246cbfbe7f230fab4cdda2
+DIST isync-1.3.3.tar.gz 315912 BLAKE2B 64a6130fd2e0b6bcb4c57e7e353c1227f65ec84b557419aaff617f9cde186e1e8f906a9448e4642bd1f6db245a769923cb8ec779ac077225c47a16160d3a8b10 SHA512 915824272606f75da8c05fb75872bc5cf528fa555024245094d14a25b190f1b813dd5723e9b87f27f3fbb14b100311ee487bc409d074a68d67e9ab675b12c7a1
diff --git a/net-mail/isync/isync-1.3.3.ebuild b/net-mail/isync/isync-1.3.3.ebuild
new file mode 100644
index 000000000000..74b81bf11ed5
--- /dev/null
+++ b/net-mail/isync/isync-1.3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="MailDir mailbox synchronizer"
+HOMEPAGE="http://isync.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="libressl sasl ssl zlib"
+
+RDEPEND="
+ >=sys-libs/db-4.2:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-lang/perl
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl) \
+ $(use_with sasl) \
+ $(use_with zlib)
+}
diff --git a/net-mail/isync/isync-9999.ebuild b/net-mail/isync/isync-9999.ebuild
index c910f9673b0a..74b81bf11ed5 100644
--- a/net-mail/isync/isync-9999.ebuild
+++ b/net-mail/isync/isync-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="MailDir mailbox synchronizer"
HOMEPAGE="http://isync.sourceforge.net/"
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3 autotools
else
SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
IUSE="libressl sasl ssl zlib"
@@ -27,7 +27,8 @@ RDEPEND="
)
zlib? ( sys-libs/zlib:0= )
"
-DEPEND="${RDEPEND}
+DEPEND=${RDEPEND}
+BDEPEND="
dev-lang/perl
"