summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-10-09 15:55:08 +0200
committerSam James <sam@gentoo.org>2021-10-20 02:38:36 +0000
commit7518bba53f569594afdd3d93a4cdfffc00b60d0b (patch)
treee0a76391d756274c1175e75f2278b35f47b808d0 /net-mail/automx2
parentsci-geosciences/grass: drop WANT_AUTOCONF from 9999 (diff)
downloadgentoo-7518bba53f569594afdd3d93a4cdfffc00b60d0b.tar.gz
gentoo-7518bba53f569594afdd3d93a4cdfffc00b60d0b.tar.bz2
gentoo-7518bba53f569594afdd3d93a4cdfffc00b60d0b.zip
net-mail/automx2: Bump to version 2021.5
Bundle upstream feature release 2021.5. Ebuild changes: - Convert DOCS and HTML_DOCS to array form. - Install docs unconditionally. They come pre-generated in the upstream archive and are but small files. - Replace "@EPYTHON@" with "python" in init script and drop the now obsolete sed statement. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/22528 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/automx2')
-rw-r--r--net-mail/automx2/Manifest1
-rw-r--r--net-mail/automx2/automx2-2021.5.ebuild46
-rw-r--r--net-mail/automx2/files/init-r126
3 files changed, 73 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index 70bd712a0710..72263a76bd5a 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1 +1,2 @@
DIST automx2-2021.4.tar.gz 170903 BLAKE2B 9c8e9bc95eeac9a8a59430248d532d540e70a40c4d61f006d5d2649198e856e4b404ed75df745cfb06887c58049a9a233a597059e2f2971bf9f1c8ce65a34f3d SHA512 f306bfdca10dc884bef404e5ff24181dc9adfb8514fd0e0d984bac84ca4996f0978eda7161be46f1b3d93a9c0e61aaabdfb4b2886012570a51ad0aaf2286dd2c
+DIST automx2-2021.5.tar.gz 172317 BLAKE2B 501dea5561d780fed538676e41dac46da01bae24388f477afa66e1b27e8a271e48bd6bddc8f9a4e0f5e7b3eb9f58fca9a9b2adaf78de2f7cd2feacfc8f85c9a4 SHA512 00281f32df6b117690d9780b8a587907518e2485dc37450765c3f35acb92a27da73ecd4e35cd05e0a5307d179ba3edaa1dec80900a059c975589ae904456c565
diff --git a/net-mail/automx2/automx2-2021.5.ebuild b/net-mail/automx2/automx2-2021.5.ebuild
new file mode 100644
index 000000000000..053aba45a4d9
--- /dev/null
+++ b/net-mail/automx2/automx2-2021.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="acct-user/automx2"
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( ${S}/docs/*.adoc ${S}/contrib/*sample.conf )
+ local HTML_DOCS=( ${S}/docs/*.{html,svg} )
+ newconfd "${FILESDIR}/confd" "${PN}"
+ newinitd "${FILESDIR}/init-r1" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/files/init-r1 b/net-mail/automx2/files/init-r1
new file mode 100644
index 000000000000..56878e8ca379
--- /dev/null
+++ b/net-mail/automx2/files/init-r1
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+: ${AUTOMX2_CONF:="/etc/${RC_SVCNAME}.conf"}
+: ${AUTOMX2_USER:="automx2"}
+: ${AUTOMX2_ARGS:="--port 4243"}
+
+command="/usr/bin/python"
+command_args="/usr/bin/flask run ${AUTOMX2_ARGS}"
+command_background="true"
+command_user="${AUTOMX2_USER}"
+pidfile="/run/${RC_SVCNAME}.pid"
+required_files="${AUTOMX2_CONF}"
+
+depend() {
+ use logger net
+ before nginx
+}
+
+start_pre() {
+ export AUTOMX2_CONF
+ export EPYTHON="python"
+ export FLASK_APP="automx2.server:app"
+ export FLASK_ENV="production"
+}