summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-12 10:56:58 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-12 10:56:58 +0100
commitfbc97e692912265a98f91eef486f89a3e80962f0 (patch)
treee1f18f644fa7859523aab0d5568d6846f8e0fc20 /net-libs
parentdev-db/postgresql: Stabilize 9.6.24 x86, #823125 (diff)
downloadgentoo-fbc97e692912265a98f91eef486f89a3e80962f0.tar.gz
gentoo-fbc97e692912265a98f91eef486f89a3e80962f0.tar.bz2
gentoo-fbc97e692912265a98f91eef486f89a3e80962f0.zip
net-libs/libyang: add 2.0.112
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libyang/Manifest1
-rw-r--r--net-libs/libyang/libyang-2.0.112.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/libyang/Manifest b/net-libs/libyang/Manifest
index d04ca62f55ad..c269392d3dd0 100644
--- a/net-libs/libyang/Manifest
+++ b/net-libs/libyang/Manifest
@@ -1 +1,2 @@
+DIST libyang-2.0.112.tar.gz 1075308 BLAKE2B 13c5dee1817f93ec24580d24cfc5d1c066de54dec3d1de60e6f7d67caad527b13e40864301d5e5086b3d92b8769e200674168dd874bc2c786bd5101ec3aa958f SHA512 5da463b86656b9fc944925777a488b3306ef1a1e7efdaf4af677960a04b5544605126bb7e0441e55686b80f97fca70fe86605d0e7c64f634b4297dcc7bd779db
DIST libyang-2.0.97.tar.gz 1066042 BLAKE2B 24ad593b4d4db2c54bf083d3f3469b17de8734aded878d167e383a5e7edb964706a48707e2f0847c7cd4f613b6c1e298325710c4b074f4a3fa1102e22265d632 SHA512 f97f29703f49ef22d04ecf3071d4437417ca95fd0cc2a696269ff646076cca15236874c40ef6a891f1ed4a1173600ba4c6cdd5e0879356b53414c4f0c415c389
diff --git a/net-libs/libyang/libyang-2.0.112.ebuild b/net-libs/libyang/libyang-2.0.112.ebuild
new file mode 100644
index 000000000000..f34f5a455181
--- /dev/null
+++ b/net-libs/libyang/libyang-2.0.112.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="YANG data modeling language library"
+HOMEPAGE="https://github.com/CESNET/libyang"
+SRC_URI="https://github.com/CESNET/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/libpcre2[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ multilib_is_native_abi && use doc && cmake_src_compile doc
+}
+
+multilib_src_install_all() {
+ use doc && dodoc -r doc/.
+}