summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-08-26 02:52:40 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-08-26 02:52:40 +0200
commite15f4b1b528ef33ed13bd4ab17b8c42793e27743 (patch)
tree7627f9f698156f66c3a4321efcada8de66e7d901 /net-libs
parentx11-plugins/pidgin-opensteamworks: Version bump. (diff)
downloadgentoo-e15f4b1b528ef33ed13bd4ab17b8c42793e27743.tar.gz
gentoo-e15f4b1b528ef33ed13bd4ab17b8c42793e27743.tar.bz2
gentoo-e15f4b1b528ef33ed13bd4ab17b8c42793e27743.zip
Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/gloox-1.0.14.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index 815e0641563c..a1329e3c4ac8 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1,2 +1,3 @@
DIST gloox-1.0.13.tar.bz2 675842 SHA256 4d9f1eeac97c6563dde11d4bdba346a025ef27908b088b47b5c8d3d03df6ea8a SHA512 9f9773a5c3d2ae8a4eec6e8365c8578c089004d0f5101c2e8a8bf96ac8e8b6a08cf4e92f93afb8d07af0e8cc2c238c12f4f8df75a81c2a06dfb039c1d4ae850a WHIRLPOOL 772b18a22acff536abb378a4307c6dcb3b9b35b231d061f05b22d5cb260d8da3c0356bdbca0a8cac9feab0fbc9124bc41472b91a335215291e1e66a9184ccc78
+DIST gloox-1.0.14.tar.bz2 696719 SHA256 520b72a66fa9fea917a0336872101539f0bea30d1f871e12c31b6c2cd0203941 SHA512 0c3242bbb9713e944b9b4926ea7588434c52ae78a1fadc0b2a6da9677303550e805d1f570188a464806a9d56242efb50d268f65b3f661ed3a4df1b7055046b77 WHIRLPOOL 2ed53195b8658112167195749c3e58b451c587c7530bdf2197eb77a750344e92d0e4c13843997e3098c51512ecd45943d6849ec60a7953a55a2420b072ca622d
DIST gloox-1.0.9.tar.bz2 670206 SHA256 143dd50e1edc4eb1d304fa28bdd6ab9e53b60c37c1726dd0e34c06c51f9a453e SHA512 a3fa7acc76fdca0421030e71b6a13ca0b04589946df2a781609f1bddae5329299d68ce99a4a94a0760206b112759636379ce67d220422b99302fc799964bfa22 WHIRLPOOL 414eb34fa3ec11ae929f84198d95ed0da9de0739655ae1188ac3eb03998de5cecb9c165ad284496b405b49126236b628dc5b4579e855b10377add145fabb63b1
diff --git a/net-libs/gloox/gloox-1.0.14.ebuild b/net-libs/gloox/gloox-1.0.14.ebuild
new file mode 100644
index 000000000000..f3cefc940158
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/13"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~ia64 ~sparc ~x86"
+IUSE="debug gnutls idn ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl:0 )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ econf \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
+ $(use_with idn libidn) \
+ $(use_with gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with test tests) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}