summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-09 10:31:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-09 10:31:37 +0100
commitcded0f1fbf0cdfd60787b7ab01eaf677c62869d9 (patch)
treebf7db3c450b7acdb349b4c9dc71b322db7609add /net-libs
parentpackage.mask: Last rite dev-util/waf (diff)
downloadgentoo-cded0f1fbf0cdfd60787b7ab01eaf677c62869d9.tar.gz
gentoo-cded0f1fbf0cdfd60787b7ab01eaf677c62869d9.tar.bz2
gentoo-cded0f1fbf0cdfd60787b7ab01eaf677c62869d9.zip
net-libs/nfqueue-bindings: Remove last-rited pkg
Closes: https://bugs.gentoo.org/692340 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nfqueue-bindings/Manifest2
-rw-r--r--net-libs/nfqueue-bindings/metadata.xml13
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild71
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild69
4 files changed, 0 insertions, 155 deletions
diff --git a/net-libs/nfqueue-bindings/Manifest b/net-libs/nfqueue-bindings/Manifest
deleted file mode 100644
index ed87ac5eff91..000000000000
--- a/net-libs/nfqueue-bindings/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST nfqueue-bindings-0.5.tar.gz 22385 BLAKE2B dd14df558dcc3f811f7f649f0e4ef305025f863d850deceae0dba308974865150265899d3cee43d2a279d6c6d6237dd4df6b01b72c39b6a96819d25fa4413dbe SHA512 c88ef6997b8e4b3ae2c2eb6c1002b74f39979c73b4dc3a4da428aa4eeb6eedeeaff1cbc27c0740e8b29fb8b6a6f98af326be0b4fbc6ed3e432a9884febb3f7a6
-DIST nfqueue-bindings-0.6.tar.gz 22425 BLAKE2B e338268a41e29cbab9a5dc2e891caa78a75d7849439fd9afc8eb105c965e8d201d854f95460d337dc60249ee2c90d88582075a14bc321bf5b952e5a8b648ed0e SHA512 6ee31b01377c0e4b6aa2d2f2e14b34d4d432f04d0e813f90a9d7e52ea9c8483044f7a36b48220887d658c80ca07bfefc88f8aa92309cff30619ec8fb9f52ab43
diff --git a/net-libs/nfqueue-bindings/metadata.xml b/net-libs/nfqueue-bindings/metadata.xml
deleted file mode 100644
index 96c116c350b6..000000000000
--- a/net-libs/nfqueue-bindings/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>chutzpah@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">chifflier/nfqueue-bindings</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
deleted file mode 100644
index 97d6ee2d4ac5..000000000000
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils perl-module linux-info python-single-r1
-
-DESCRIPTION="High-level language bindings for libnetfilter_queue"
-HOMEPAGE="https://github.com/chifflier/nfqueue-bindings"
-SRC_URI="https://github.com/chifflier/nfqueue-bindings/archive/nfqueue-bindings-0.5.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-3"
-IUSE="perl python examples"
-REQUIRED_USE="|| ( perl python ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? (
- $(python_gen_cond_dep '
- dev-python/dpkt[${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}
- )"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/perl )
- net-libs/libnetfilter_queue
- dev-lang/swig"
-
-S=${WORKDIR}/${PN}-${P}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- # At least one of Python or Perl must be selected
- use python || useq perl || die "At least one supported language must be selected."
- # Check kernel configuration for NFQUEUE
- if linux_config_exists; then
- ebegin "Checking NETFILTER_NETLINK_QUEUE support"
- linux_chkconfig_present NETFILTER_NETLINK_QUEUE
- eend $? || \
- eerror 'Netfilter NFQUEUE over NFNETLINK interface support not found!'
- ebegin "Checking NETFILTER_XT_TARGET_NFQUEUE support"
- linux_chkconfig_present NETFILTER_XT_TARGET_NFQUEUE
- eend $? || \
- eerror '"NFQUEUE" target Support not found!'
- fi
-}
-
-src_prepare() {
- if use perl; then
- # Fix Perl destination directory
- perl_set_version
- sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
- else
- sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
- fi
-
- if use python; then
- sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
- else
- sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install PREFIX=/usr
- docinto examples
- use examples && dodoc examples/*
-}
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild
deleted file mode 100644
index 56b6ed038b47..000000000000
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils perl-module linux-info python-single-r1
-
-DESCRIPTION="High-level language bindings for libnetfilter_queue"
-HOMEPAGE="https://github.com/chifflier/nfqueue-bindings"
-SRC_URI="https://github.com/chifflier/nfqueue-bindings/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-3"
-IUSE="perl python examples"
-REQUIRED_USE="|| ( perl python ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? (
- $(python_gen_cond_dep '
- dev-python/dpkt[${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}
- )"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/perl )
- net-libs/libnetfilter_queue
- dev-lang/swig"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- # At least one of Python or Perl must be selected
- use python || useq perl || die "At least one supported language must be selected."
- # Check kernel configuration for NFQUEUE
- if linux_config_exists; then
- ebegin "Checking NETFILTER_NETLINK_QUEUE support"
- linux_chkconfig_present NETFILTER_NETLINK_QUEUE
- eend $? || \
- eerror 'Netfilter NFQUEUE over NFNETLINK interface support not found!'
- ebegin "Checking NETFILTER_XT_TARGET_NFQUEUE support"
- linux_chkconfig_present NETFILTER_XT_TARGET_NFQUEUE
- eend $? || \
- eerror '"NFQUEUE" target Support not found!'
- fi
-}
-
-src_prepare() {
- if use perl; then
- # Fix Perl destination directory
- perl_set_version
- sed -i "s|\${LIB_INSTALL_DIR}/perl\${PERL_VERSION}/|${VENDOR_ARCH}|" perl/CMakeLists.txt || die
- else
- sed -i 's|ADD_SUBDIRECTORY(perl)||' CMakeLists.txt || die
- fi
-
- if use python; then
- sed -i "s|\${LIB_INSTALL_DIR}/python\${PYTHON_VERSION}/dist-packages/|$(python_get_sitedir)|" python/CMakeLists.txt || die
- else
- sed -i 's|ADD_SUBDIRECTORY(python)||' CMakeLists.txt || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install PREFIX=/usr
- docinto examples
- use examples && dodoc examples/*
-}