summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-02 09:40:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-02 09:50:58 +0100
commit5fc35e51de35bfd695a88b9ccc1cc64237a9ea53 (patch)
tree5024e9c0d09eab8ec9d037748566199bf7afa650 /net-libs
parentnet-misc/curl: version bump to 7.46.0, happy 150th release! (diff)
downloadgentoo-5fc35e51de35bfd695a88b9ccc1cc64237a9ea53.tar.gz
gentoo-5fc35e51de35bfd695a88b9ccc1cc64237a9ea53.tar.bz2
gentoo-5fc35e51de35bfd695a88b9ccc1cc64237a9ea53.zip
net-libs/gsoap: Bump to version 2.8.26
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.26.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index aeb5da10bb6b..8b232a98ee56 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -3,3 +3,4 @@ DIST gsoap_2.8.12.zip 19974348 SHA256 51eef118544fa846f4d2dea2eedf91c84c46a1abea
DIST gsoap_2.8.23.zip 22482000 SHA256 e1c30743f1c2cf40b2760568127e14af1b2a00c3026b2e5f0750e8c33d94c061 SHA512 cc90aadfe09aa6406172c9ffa07696851ff594ca7c5b40819494badd8ce978d908d66de63a5831e7aec1bca18ee8b51ed02187057688a3b36eb0a21fe6e0f5a4 WHIRLPOOL e5cfc9c5758847d1fc94cbd38108b80c7548abc0316fe201b58604a3b22d30b9748c81d4aec13f53356593f3ddc2dcba14170a53d63795eab9229ec49d4bc585
DIST gsoap_2.8.24.zip 23449177 SHA256 6c67bdda7ce9cff62e1faa33c53fb38aa256e2af48b2645a0e5a43142f88b7e8 SHA512 20cad888aa75aa4f715e1120375be7e430554fd0626b8e8684da190ca0547b0d506aac1bc971a674116899fb0fccbb7bc73d03ea46d9af48d72c62e0dfe8e7a7 WHIRLPOOL 37f475317cdfc625b995a67c62f5275950ef886b478ac3adec1402431429650b29406cb45d411b12972d347a1fe176fdbcdbe8f87dc371080418e9bb5566a4a2
DIST gsoap_2.8.25.zip 22488537 SHA256 396b66eb7ab410d89a38d1319443d99fd8b43cab8743f9c69f03a2ed3215db05 SHA512 7571da408da919d08fa5d8d87bd343cec6f137218287f0bb3864841a5ae30c2fe917a2e7c7a892bb7f74218ba4e56ccc6dd6e0073accffe21f4f3dbc7a59fb17 WHIRLPOOL 9f627ef7e6da9e87062d0833c13a79fb974bbea910a294b13fa5efcaef0bd52a2aa9d52f20020d1663648853c6fd87f7945716a30c8809f7f298c82dfddf52ea
+DIST gsoap_2.8.26.zip 22605211 SHA256 bfe42848d324be1f7313fd01c1e953caf5ee28fbb640cbf2fa004d32123683d6 SHA512 eee9f4f34c62114f400d644fbb5f1b93dfd12e524746f8dc74d459b993ac170d09598fc254a0471d6dacf26e31298ba93b5e95381c5d9c24445acea2b6957ff5 WHIRLPOOL fecd08fcaf736d573688c643109149a75d2a64ecef15af79e13a74b4da9bad6a80278e4adeaee682c7bb0cdc37402362bb497e20e9f40104dff21d21e589d383
diff --git a/net-libs/gsoap/gsoap-2.8.26.ebuild b/net-libs/gsoap/gsoap-2.8.26.ebuild
new file mode 100644
index 000000000000..a565476706c1
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.26.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}