summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-28 16:05:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-28 16:14:42 +0200
commit56009db7797e82b9b42eb5a51111228a6e90fac1 (patch)
tree18428e0ded072872fbf3d0b28afa2fdc05b54988 /net-libs
parentmedia-video/mpv: do not hard-enable vdpau-hwaccel (diff)
downloadgentoo-56009db7797e82b9b42eb5a51111228a6e90fac1.tar.gz
gentoo-56009db7797e82b9b42eb5a51111228a6e90fac1.tar.bz2
gentoo-56009db7797e82b9b42eb5a51111228a6e90fac1.zip
net-libs/socket_wrapper: Workaround for bug #558340
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild7
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
index 640369fbb2eb..6d917488a193 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
@@ -16,3 +16,10 @@ IUSE="test"
DEPEND=""
RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
index 51b698f90753..d68a3de38e5b 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
@@ -16,3 +16,10 @@ IUSE="test"
DEPEND=""
RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}