summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-05 12:35:53 +0000
committerSam James <sam@gentoo.org>2024-01-05 12:35:53 +0000
commit21109fa861f07a6ae06cfbed1ef2c721bfae9afd (patch)
tree0ee9391ec52b2456da8e003f301a786b5419464c /net-libs
parentdev-ruby/activesupport: avoid dependency on mdl (diff)
downloadgentoo-21109fa861f07a6ae06cfbed1ef2c721bfae9afd.tar.gz
gentoo-21109fa861f07a6ae06cfbed1ef2c721bfae9afd.tar.bz2
gentoo-21109fa861f07a6ae06cfbed1ef2c721bfae9afd.zip
net-libs/webkit-gtk: filter LTO
ODR violations thanks to Bison. Fortunately, upstream are open to fixing it, it just needs a hack like GDB did, or could even maybe just do --name-prefix or something if Bison-only is OK. Closes: https://bugs.gentoo.org/866896 Closes: https://bugs.gentoo.org/915230 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.42.3-r410.ebuild5
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.42.3-r600.ebuild5
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.42.3.ebuild5
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.42.4-r410.ebuild3
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.42.4-r600.ebuild3
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.42.4.ebuild3
6 files changed, 21 insertions, 3 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.42.3-r410.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.42.3-r410.ebuild
index a6bd35a61369..67a6f3ef6fd2 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.42.3-r410.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.42.3-r410.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -159,6 +159,9 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.42.3-r600.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.42.3-r600.ebuild
index 2e7aebfed942..55fb6a6fc4ca 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.42.3-r600.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.42.3-r600.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -160,6 +160,9 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.42.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.42.3.ebuild
index 677e2a75b64d..c2dbd794b679 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.42.3.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.42.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -157,6 +157,9 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.42.4-r410.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.42.4-r410.ebuild
index c88fc397b1f9..e6dfc1c380d3 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.42.4-r410.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.42.4-r410.ebuild
@@ -161,6 +161,9 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.42.4-r600.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.42.4-r600.ebuild
index 599c268e4b4a..c8b32ef0b55a 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.42.4-r600.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.42.4-r600.ebuild
@@ -162,6 +162,9 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.42.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.42.4.ebuild
index b5ad3bd607ec..e781da1db735 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.42.4.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.42.4.ebuild
@@ -159,6 +159,9 @@ src_configure() {
# Respect CC, otherwise fails on prefix #395875
tc-export CC
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
# It does not compile on alpha without this in LDFLAGS
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"