summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/pacparser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/pacparser')
-rw-r--r--net-libs/pacparser/Manifest1
-rw-r--r--net-libs/pacparser/files/pacparser-1.3.1-makefile.patch66
-rw-r--r--net-libs/pacparser/metadata.xml26
-rw-r--r--net-libs/pacparser/pacparser-1.3.1.ebuild53
4 files changed, 146 insertions, 0 deletions
diff --git a/net-libs/pacparser/Manifest b/net-libs/pacparser/Manifest
new file mode 100644
index 000000000000..7eb5deafff1a
--- /dev/null
+++ b/net-libs/pacparser/Manifest
@@ -0,0 +1 @@
+DIST pacparser-1.3.1.tar.gz 1229362 SHA256 040fb94c420f6aaad295b0b60cf1659f996fee1997c332bec2a6390955276585 SHA512 20295667d92eb5385429c085c14ca8dc1ba216487ff474304433f99119216934be2dd1647452173418de31f5345679dd7159eafd331e40a2b87564f878d31349 WHIRLPOOL 47caf428b4574d9fbb40cffe46afb38cc6bb786382805754f1653e3d554af60e695e1718902c94822b229b7fb4f9748257745a1b3faedfa02cc7b06ba457768f
diff --git a/net-libs/pacparser/files/pacparser-1.3.1-makefile.patch b/net-libs/pacparser/files/pacparser-1.3.1-makefile.patch
new file mode 100644
index 000000000000..a1434075d18a
--- /dev/null
+++ b/net-libs/pacparser/files/pacparser-1.3.1-makefile.patch
@@ -0,0 +1,66 @@
+diff -Nur pacparser-1.3.1.orig/src/Makefile pacparser-1.3.1/src/Makefile
+--- pacparser-1.3.1.orig/src/Makefile 2013-11-26 04:21:24.000000000 +0000
++++ pacparser-1.3.1/src/Makefile 2013-11-26 04:27:11.000000000 +0000
+@@ -55,7 +55,7 @@
+ endif
+ endif
+
+-CFLAGS = -g -DXP_UNIX -Wall -DVERSION=$(VERSION)
++CFLAGS := $(CFLAGS) -g -DXP_UNIX -Wall -DVERSION=$(VERSION)
+
+ ifndef PYTHON
+ PYTHON = python
+@@ -67,13 +67,14 @@
+
+ LIBRARY_LINK = $(LIBRARY_NAME).$(SO_SUFFIX)
+ PREFIX := $(DESTDIR)$(PREFIX)
+-LIB_PREFIX = $(PREFIX)/lib
+-INC_PREFIX = $(PREFIX)/include
+-BIN_PREFIX = $(PREFIX)/bin
+-MAN_PREFIX = $(PREFIX)/share/man
++LIB_PREFIX := $(PREFIX)/lib
++INC_PREFIX := $(PREFIX)/include
++BIN_PREFIX := $(PREFIX)/bin
++MAN_PREFIX := $(PREFIX)/share/man
++DOC_PREFIX := $(PREFIX)/share/doc/pacparser
+
+ .PHONY: clean pymod install-pymod
+-all: testpactester
++all: pactester
+
+ spidermonkey/js/src: spidermonkey/js-?.?.?.tar.gz
+ tar xzvf spidermonkey/js-?.?.?.tar.gz -C spidermonkey
+@@ -97,7 +98,7 @@
+ ln -sf $(LIBRARY) $(LIBRARY_LINK)
+
+ pactester: pactester.c pacparser.h $(LIBRARY_LINK)
+- $(CC) pactester.c -o pactester -lpacparser -L. -I.
++ $(CC) $(CFLAGS) $(LDFLAGS) pactester.c -o pactester -lpacparser -L. -I.
+
+ testpactester: pactester
+ echo "Running tests for pactester."
+@@ -118,16 +119,20 @@
+ # install pacparser manpages
+ install -d $(MAN_PREFIX)/man3/
+ (test -d ../docs && install -m 644 ../docs/man/man3/*.3 $(MAN_PREFIX)/man3/) || true
++
++install-docs:
+ # install html docs
+- install -d $(PREFIX)/share/doc/pacparser/html/
+- (test -d ../docs/html && install -m 644 ../docs/html/* $(PREFIX)/share/doc/pacparser/html/) || true
++ install -d $(DOC_PREFIX)/html/
++ (test -d ../docs/html && install -m 644 ../docs/html/* $(DOC_PREFIX)/html/) || true
+ # install examples
+- install -d $(PREFIX)/share/doc/pacparser/examples/
+- (test -d ../examples && install -m 644 ../examples/* $(PREFIX)/share/doc//pacparser/examples/) || true
++ install -d $(DOC_PREFIX)/examples/
++ (test -d ../examples && install -m 644 ../examples/* $(DOC_PREFIX)/examples/) || true
+
+ # Targets to build python module
+ pymod: pacparser.o pacparser.h libjs.a
+ cd pymod && ARCHFLAGS="" $(PYTHON) setup.py build
++
++test-pymod: pymod
+ $(PYTHON) ../tests/runtests.py
+
+ install-pymod: pymod
diff --git a/net-libs/pacparser/metadata.xml b/net-libs/pacparser/metadata.xml
new file mode 100644
index 000000000000..67c25ef2c2c0
--- /dev/null
+++ b/net-libs/pacparser/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+</maintainer>
+<longdescription>
+ A library to parse proxy auto-config (PAC) files. Proxy auto-config
+ files are a vastly used proxy configuration method these days. Web
+ browsers can use a PAC file to determine which proxy server to use
+ or whether to go direct for a given URL. PAC files are written in
+ JavaScript and can be programmed to return different proxy methods
+ (e.g. "PROXY proxy1:port; DIRECT") depending upon URL, source IP
+ address, protocol, time of the day etc. PAC files introduce a lot
+ of possibilities.
+ Needless to say, PAC files are now a widely accepted method for
+ proxy configuration management and companies all over are using
+ them in corporate environments. Almost all popular web browsers
+ support PAC files. The idea behind pacparser is to make it easy to
+ add this PAC file parsing capability to any program (C and Python
+ supported right now).
+</longdescription>
+<upstream>
+ <remote-id type="google-code">pacproxy</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/net-libs/pacparser/pacparser-1.3.1.ebuild b/net-libs/pacparser/pacparser-1.3.1.ebuild
new file mode 100644
index 000000000000..5f631d081f00
--- /dev/null
+++ b/net-libs/pacparser/pacparser-1.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit eutils python-r1 multilib
+
+DESCRIPTION="Library to parse proxy auto-config files"
+HOMEPAGE="http://code.google.com/p/pacparser/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python"
+
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# spidermonkey-1.7.0 is bundled
+# tested unbundling with spidermonkey-1.8* and 17
+# failures : unbundling not worth
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ export NO_INTERNET=yes
+}
+
+src_compile() {
+ emake -j1 -C src
+ use python && python_foreach_impl emake -j1 -C src pymod
+}
+
+src_test() {
+ emake -j1 -C src testpactester
+ use python && emake -j1 -C src test-pymod
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIB_PREFIX="${ED}/usr/$(get_libdir)" -C src install
+ dodoc README
+ use python && python_foreach_impl \
+ emake DESTDIR="${D}" \
+ LIB_PREFIX="${D}/usr/$(get_libdir)" -C src install-pymod
+ use doc && emake DESTDIR="${ED}" \
+ DOC_PREFIX="${ED}/usr/share/doc/${PF}" -C src install-docs
+ # conflicts (bug #509168), and useless
+ rm "${ED}"/usr/share/man/man3/deprecated.3 || die
+}