summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-13 15:51:49 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-13 18:25:03 +0100
commit19add7ba6500e6c60c8699b6bdda397744dfa73b (patch)
tree5e00ab7e10588567be9c92baa79c6472b1b169de /net-libs/nodejs/nodejs-99999999.ebuild
parentnet-libs/nodejs-12.18.4-r1: drop ppc keyword (diff)
downloadgentoo-19add7ba6500e6c60c8699b6bdda397744dfa73b.tar.gz
gentoo-19add7ba6500e6c60c8699b6bdda397744dfa73b.tar.bz2
gentoo-19add7ba6500e6c60c8699b6bdda397744dfa73b.zip
net-libs/nodejs: drop PaX support altogether
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/nodejs/nodejs-99999999.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index e7a2c7c7eb93..65d30862d4c6 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 flag-o-matic git-r3 python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -13,7 +13,7 @@ EGIT_REPO_URI="https://github.com/nodejs/node"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS=""
-IUSE="cpu_flags_x86_sse2 debug doc +icu inspector +npm pax_kernel +snapshot +ssl +system-ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc +icu inspector +npm +snapshot +ssl +system-ssl systemtap test"
RESTRICT="!test? ( test )"
REQUIRED_USE="
inspector? ( icu ssl )
@@ -35,7 +35,6 @@ BDEPEND="
sys-apps/coreutils
systemtap? ( dev-util/systemtap )
test? ( net-misc/curl )
- pax_kernel? ( sys-apps/elfix )
"
DEPEND="
${RDEPEND}
@@ -84,9 +83,6 @@ src_prepare() {
BUILDTYPE=Debug
fi
- # We need to disable mprotect on two files when it builds Bug 694100.
- use pax_kernel && PATCHES+=( "${FILESDIR}"/${PN}-13.2.0-paxmarking.patch )
-
default
}
@@ -140,8 +136,6 @@ src_install() {
local LIBDIR="${ED}/usr/$(get_libdir)"
default
- pax-mark -m "${ED}"/usr/bin/node
-
# set up a symlink structure that node-gyp expects..
dodir /usr/include/node/deps/{v8,uv}
dosym . /usr/include/node/src