summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-10 16:23:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-10 16:41:37 +0200
commit4bdb0cb9607959f8dccd460e7e1dce65cba3eb20 (patch)
treef6e9e219b01475785391da288a6b92f38d3d546e /net-libs/miniupnpc
parentdev-python/jsonpickle: Add a numpy-2 patch (diff)
downloadgentoo-4bdb0cb9607959f8dccd460e7e1dce65cba3eb20.tar.gz
gentoo-4bdb0cb9607959f8dccd460e7e1dce65cba3eb20.tar.bz2
gentoo-4bdb0cb9607959f8dccd460e7e1dce65cba3eb20.zip
net-libs/miniupnpc: Bump to 2.2.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/miniupnpc')
-rw-r--r--net-libs/miniupnpc/Manifest2
-rw-r--r--net-libs/miniupnpc/miniupnpc-2.2.8.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/Manifest b/net-libs/miniupnpc/Manifest
index 1bfa020c464e..1ae860948ae7 100644
--- a/net-libs/miniupnpc/Manifest
+++ b/net-libs/miniupnpc/Manifest
@@ -1,2 +1,4 @@
DIST miniupnpc-2.2.7.tar.gz 104258 BLAKE2B 5681c1747c8e330442a0ad46d673e1739283bfc23571cb2225abf82326caa7da979911b3182cab2e3eea49140b90619f4e00bb5b1e2f0cd6067c28017cf87016 SHA512 d24e653c2f7bfed4485342c5ec8d18b4dd4c3430975b5fae392d3534f38bb3fb59e6638e76d57847f49045e22f3afd6cac128d7d9d10ef05bd6ad24ef38303b6
DIST miniupnpc-2.2.7.tar.gz.sig 543 BLAKE2B 6649e5866afd13034b05a9d771c25c419e85631ca17ed7457e5811aee0ba8c38b0ad34033caa5b611cde21a63251e902e3f24cc4748e52a4a379ef075bf59dc5 SHA512 188837275b20c61c05babac916bff86178774030dbc191ecd0e5314c6e9b6dbb627680b512c554a8b27a020bd7503b141be26a134e0ed7e2cc56c7e2c01d9e81
+DIST miniupnpc-2.2.8.tar.gz 104603 BLAKE2B eae4d97bdf8c494ea6744edfeb870f9d92df8468d23f974e0e44e735fc7c8925189ea58f60a71c37315aebff1269ae69e9413cdf80dc292c4b90df5f12bf58a4 SHA512 526c9df1485302d4c9c78062fb058cfd433463f6e7a9f4025a9f5228aef41ee61a4b9e7a76b6cfa8779b91cc3c663846a997dc1470902d7108b129155e6a3360
+DIST miniupnpc-2.2.8.tar.gz.sig 543 BLAKE2B b4d056972fc7e46c1e41a658d301db8e9a0d3b99af2220c264d06267b4e8ae45847e2bf2cd6583fded67f12c2e0a3c833ba7e38d9c05b5a0cc363e0c1fc8feae SHA512 b5eec0d24a84183021cd16bfd6ecedda587dee0bbb017fe6d107e8c2815ef90cf5f904c6fb9aa32e2e4d5f0b63de8566814c9a0d921b338b26b60ea35c23ecae
diff --git a/net-libs/miniupnpc/miniupnpc-2.2.8.ebuild b/net-libs/miniupnpc/miniupnpc-2.2.8.ebuild
new file mode 100644
index 000000000000..bb03067c5ae4
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-2.2.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="
+ http://miniupnp.free.fr/
+ https://miniupnp.tuxfamily.org/
+ https://github.com/miniupnp/miniupnp/
+"
+SRC_URI="
+ https://miniupnp.tuxfamily.org/files/${P}.tar.gz
+ verify-sig? (
+ https://miniupnp.tuxfamily.org/files/${P}.tar.gz.sig
+ )
+"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ kernel_linux? ( sys-apps/lsb-release )
+ verify-sig? ( sec-keys/openpgp-keys-miniupnp )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/miniupnp.asc
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/miniupnpc-2.2.3-drop-which.patch
+ )
+ default
+
+ local exprs=(
+ # These bins are not installed, upnpc-static requires building static lib
+ -e '/EXECUTABLES =/s/ upnpc-static upnp-listdevices-static//'
+ # Prevent gzipping manpage.
+ -e '/gzip/d'
+ # Disable installing the static library
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//'
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d'
+ )
+ sed -i "${exprs[@]}" Makefile || die
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC AR
+ emake build/upnpc-shared
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="$(get_libdir)" \
+ install
+
+ dodoc README Changelog.txt
+}