summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 17:38:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 21:30:53 +0100
commitc58dae8d82bb05485a2a48cb7460cd2f954e2187 (patch)
tree62460bbc78c54caefafc5fe8b0e3a05a8ac852ed /net-libs/kdsoap-ws-discovery-client
parentnet-libs/kdsoap: 1.10.0 version bump (diff)
downloadgentoo-c58dae8d82bb05485a2a48cb7460cd2f954e2187.tar.gz
gentoo-c58dae8d82bb05485a2a48cb7460cd2f954e2187.tar.bz2
gentoo-c58dae8d82bb05485a2a48cb7460cd2f954e2187.zip
net-libs/kdsoap-ws-discovery-client: 0.2_pre20200927 version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/kdsoap-ws-discovery-client')
-rw-r--r--net-libs/kdsoap-ws-discovery-client/Manifest1
-rw-r--r--net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200927.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/kdsoap-ws-discovery-client/Manifest b/net-libs/kdsoap-ws-discovery-client/Manifest
index 83d1d976ff27..7dac6647d177 100644
--- a/net-libs/kdsoap-ws-discovery-client/Manifest
+++ b/net-libs/kdsoap-ws-discovery-client/Manifest
@@ -1 +1,2 @@
DIST kdsoap-ws-discovery-client-0.2_pre20200317.tar.gz 37395 BLAKE2B 03bee2d6f87a3fb407e0cff7e84f9bd83814d742f714630b8c469b26a139062472ad39a0f743caac6f5de4ae2c8a55c42b56ee14c6afcd3a0a874c3f0d9978c5 SHA512 f99092e06e4d7496d6fe79e4cf78265c072476159da958c2a0ee7b852be00b16c89582a8c69c5cbe4160a6419435ee2d8bc71bce40ea9753eaf458c34df6f86b
+DIST kdsoap-ws-discovery-client-0.2_pre20200927.tar.gz 37493 BLAKE2B c0dff21554bc56c4055c74a166a85186d67b0378f7bfbfcd3582ae7b992aaa71cefb6b794258fa07b37fcdd1d42ac2bf9fbfd7cd8142f8f77b1ba9791d683dae SHA512 86f8c4eee3fd484253ee91190092a9ae0dbd3d0c536ec25a6e3ec35be45d4a3d320cffbfc0ed2024d447788b43c9df88ca81181157720ce8942c9034d4eea49f
diff --git a/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200927.ebuild b/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200927.ebuild
new file mode 100644
index 000000000000..74f1eb852d13
--- /dev/null
+++ b/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200927.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="true"
+inherit ecm
+
+if [[ ${PV} != *9999* ]]; then
+ COMMIT=dcefb65c88e76f1f9eda8b0318006e93d15a0e1e
+ SRC_URI="https://gitlab.com/caspermeijn/${PN}/repository/${COMMIT}/archive.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT}-${COMMIT}"
+else
+ EGIT_REPO_URI="https://gitlab.com/caspermeijn/${PN}.git"
+ inherit git-r3
+fi
+
+DESCRIPTION="WS-Discovery client library based on KDSoap"
+HOMEPAGE="https://gitlab.com/caspermeijn/kdsoap-ws-discovery-client
+https://caspermeijn.gitlab.io/kdsoap-ws-discovery-client"
+
+LICENSE="CC0-1.0 GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ >=net-libs/kdsoap-1.9.0:="
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qtxml:5 )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2_pre20200317-no-install-docs.patch )
+
+src_prepare() {
+ ecm_src_prepare
+ use test || ecm_punt_bogus_dep Qt5 Xml
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package doc Doxygen)
+ -DBUILD_QCH=OFF # does not use ecm_add_qch from ECMAddQch
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ ecm_src_install
+}