summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/ftplib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/ftplib')
-rw-r--r--net-libs/ftplib/Manifest3
-rw-r--r--net-libs/ftplib/files/ftplib-4.0-crash.patch116
-rw-r--r--net-libs/ftplib/ftplib-3.1.1.ebuild44
-rw-r--r--net-libs/ftplib/ftplib-4.0-r1.ebuild46
-rw-r--r--net-libs/ftplib/ftplib-4.0.ebuild37
-rw-r--r--net-libs/ftplib/metadata.xml8
6 files changed, 254 insertions, 0 deletions
diff --git a/net-libs/ftplib/Manifest b/net-libs/ftplib/Manifest
new file mode 100644
index 000000000000..237209ec65ae
--- /dev/null
+++ b/net-libs/ftplib/Manifest
@@ -0,0 +1,3 @@
+DIST ftplib-4.0.tar.gz 66680 SHA256 a9fabf1fdb2d6cc3713fd5413724ecc266f438a53a24595619080db9e51426a1 SHA512 ff39c243a6acbb67a8d2779f34b59f69f45d578ea3976c14aee1abcc56bf16cbbc6518ba96a4ccf34f6dd469eef388043caf066858b8df24bebfab7ab30a1c62 WHIRLPOOL 710035aa579611790d1991c0f48628c808a703f410db4d2f545b099449e3c3d3a76897d01ae1c50f47485f4b7b76492f1e2ac52445a4cc9264c41208f84500db
+DIST ftplib_3.1-1-9.debian.tar.gz 8560 SHA256 92aa7dc894cc144d3f92c7a5e60f1ea57c78eef2f93e4449242ad03aaef50644 SHA512 c87fb17bca4616d85f064f718161071b35a0e3f1c84ce8f13b4cd9f9b75f5115a4c518680d77af240196f0b2ee5eff520e0d4a0b87c797554c1ee8caa4962e07 WHIRLPOOL 6545603c973516a9fb180da3f39b741eb84e9cb2b383e4eff4ff75c55271c2e73d2547b790f841135688b5a7ec4fc1a6f95c8ff1745bea10c4ff2a73ecac0b62
+DIST ftplib_3.1-1.orig.tar.gz 90724 SHA256 64161ea4aeb1a1314eb821584521f97a1cac18b01e77722687666a1835a0b76d SHA512 5a0116ce1526f77532ced94c00bc1199378da1e1707c86637c83c6e9a27fef3a290bfefb7fc537946219587625b39560399cf136b83878a7829a2f3bee5f926f WHIRLPOOL 21df0807a5d3fa506cc6c10c7116f268b08cbab2af187aa6cc96c3b63fb0e1cc1b61ef32d1bb6c4f99d9122adc579a75d97095ae530abb112cd6fe38c472be19
diff --git a/net-libs/ftplib/files/ftplib-4.0-crash.patch b/net-libs/ftplib/files/ftplib-4.0-crash.patch
new file mode 100644
index 000000000000..c984e2d81b19
--- /dev/null
+++ b/net-libs/ftplib/files/ftplib-4.0-crash.patch
@@ -0,0 +1,116 @@
+include sys/select.h for the select() prototype on unix systems.
+
+fix warning about using chars as subscripts in arrays. on many systems, isdigit
+turns into an index of an array, so the pnum char needs to be casted to an int.
+the spec says these funcs take an int, not a char.
+
+fix warnings about the rv return value being uninitialized in FtpAcceptConnection.
+
+fix a crasher in FtpClose where it derefs the ctrl pointer before checking
+if it's NULL.
+
+fix the FtpQuit API to return 0/1 as it's documented so the caller can detect.
+
+patch by Mike Frysinger <vapier@gentoo.org>
+
+--- a/src/ftplib.c
++++ b/src/ftplib.c
+@@ -31,6 +32,7 @@
+ #if defined(__unix__)
+ #include <sys/time.h>
+ #include <sys/types.h>
++#include <sys/select.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+@@ -453,7 +456,7 @@ GLOBALDEF int FtpConnect(const char *hos
+ pnum = "ftp";
+ else
+ *pnum++ = '\0';
+- if (isdigit(*pnum))
++ if (isdigit((int)*pnum))
+ sin.sin_port = htons(atoi(pnum));
+ else
+ {
+@@ -841,7 +862,7 @@ static int FtpAcceptConnection(netbuf *n
+ int i;
+ struct timeval tv;
+ fd_set mask;
+- int rv;
++ int rv = 0;
+
+ FD_ZERO(&mask);
+ FD_SET(nControl->handle, &mask);
+@@ -858,14 +879,12 @@ static int FtpAcceptConnection(netbuf *n
+ sizeof(nControl->response));
+ net_close(nData->handle);
+ nData->handle = 0;
+- rv = 0;
+ }
+ else if (i == 0)
+ {
+ strcpy(nControl->response, "timed out waiting for connection");
+ net_close(nData->handle);
+ nData->handle = 0;
+- rv = 0;
+ }
+ else
+ {
+@@ -885,7 +904,6 @@ static int FtpAcceptConnection(netbuf *n
+ strncpy(nControl->response, strerror(i),
+ sizeof(nControl->response));
+ nData->handle = 0;
+- rv = 0;
+ }
+ }
+ else if (FD_ISSET(nControl->handle, &mask))
+@@ -893,7 +911,6 @@ static int FtpAcceptConnection(netbuf *n
+ net_close(nData->handle);
+ nData->handle = 0;
+ readresp('2', nControl);
+- rv = 0;
+ }
+ }
+ return rv;
+@@ -1054,10 +1054,11 @@ GLOBALDEF int FtpClose(netbuf *nData)
+ net_close(nData->handle);
+ ctrl = nData->ctrl;
+ free(nData);
+- ctrl->data = NULL;
+- if (ctrl && ctrl->response[0] != '4' && ctrl->response[0] != 5)
++ if (ctrl)
+ {
+- return(readresp('2', ctrl));
++ ctrl->data = NULL;
++ if (ctrl->response[0] != '4' && ctrl->response[0] != 5)
++ return readresp('2', ctrl);
+ }
+ return 1;
+ case FTPLIB_CONTROL:
+@@ -1442,12 +1443,13 @@ GLOBALDEF int FtpDelete(const char *fnm, netbuf *nControl)
+ *
+ * return 1 if successful, 0 otherwise
+ */
+-GLOBALDEF void FtpQuit(netbuf *nControl)
++GLOBALDEF int FtpQuit(netbuf *nControl)
+ {
+ if (nControl->dir != FTPLIB_CONTROL)
+- return;
++ return 0;
+ FtpSendCmd("QUIT",'2',nControl);
+ net_close(nControl->handle);
+ free(nControl->buf);
+ free(nControl);
++ return 1;
+ }
+--- a/src/ftplib.h
++++ b/src/ftplib.h
+@@ -111,7 +111,7 @@ GLOBALREF int FtpPut(const char *input, const char *path, char mode,
+ netbuf *nControl);
+ GLOBALREF int FtpRename(const char *src, const char *dst, netbuf *nControl);
+ GLOBALREF int FtpDelete(const char *fnm, netbuf *nControl);
+-GLOBALREF void FtpQuit(netbuf *nControl);
++GLOBALREF int FtpQuit(netbuf *nControl);
+
+ #ifdef __cplusplus
+ };
diff --git a/net-libs/ftplib/ftplib-3.1.1.ebuild b/net-libs/ftplib/ftplib-3.1.1.ebuild
new file mode 100644
index 000000000000..0a80ac6e8028
--- /dev/null
+++ b/net-libs/ftplib/ftplib-3.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib toolchain-funcs versionator
+
+DEB_REV=9
+MY_PV=$(replace_version_separator 2 -)
+
+DESCRIPTION="A set of routines that implement the FTP protocol"
+HOMEPAGE="http://nbpfaus.net/~pfau/ftplib/"
+DEB_URI="mirror://debian/pool/main/f/${PN}"
+SRC_URI="${DEB_URI}/${PN}_${MY_PV}.orig.tar.gz
+ ${DEB_URI}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/{check-getservbyname-failure,fix-ascii-read-without-eol}
+
+ sed -i \
+ -e '/shared/s:$(CC):$(CC) $(LDFLAGS):' \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e "s:/lib:/$(get_libdir):" \
+ linux/Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake -C linux DEBUG="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/bin /usr/include /usr/$(get_libdir)
+ emake -C linux DESTDIR="${D}" install
+ dodoc additional_rfcs CHANGES ftplib.lsm NOTES README* RFC959.txt TODO
+}
diff --git a/net-libs/ftplib/ftplib-4.0-r1.ebuild b/net-libs/ftplib/ftplib-4.0-r1.ebuild
new file mode 100644
index 000000000000..9afad088aa30
--- /dev/null
+++ b/net-libs/ftplib/ftplib-4.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib multilib-minimal toolchain-funcs eutils
+
+DESCRIPTION="A set of routines that implement the FTP protocol"
+HOMEPAGE="http://nbpfaus.net/~pfau/ftplib/"
+SRC_URI="http://nbpfaus.net/~pfau/ftplib/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '/shared/s:$(CC):$(CC) $(LDFLAGS):' \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e '/ar -rcs/s:ar:$(AR):' \
+ src/Makefile || die
+ epatch "${FILESDIR}"/${PN}-4.0-crash.patch
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake -C src \
+ DEBUG="${CFLAGS} ${CPPFLAGS}" \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ dodir /usr/bin /usr/include /usr/$(get_libdir)
+ emake -C src DESTDIR="${ED}" install
+}
+
+multilib_src_install_all() {
+ dodoc additional_rfcs CHANGES README* RFC959.txt
+ dohtml html/*
+}
diff --git a/net-libs/ftplib/ftplib-4.0.ebuild b/net-libs/ftplib/ftplib-4.0.ebuild
new file mode 100644
index 000000000000..9ec70207a44b
--- /dev/null
+++ b/net-libs/ftplib/ftplib-4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib toolchain-funcs versionator
+
+DESCRIPTION="A set of routines that implement the FTP protocol"
+HOMEPAGE="http://nbpfaus.net/~pfau/ftplib/"
+SRC_URI="http://nbpfaus.net/~pfau/ftplib/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '/shared/s:$(CC):$(CC) $(LDFLAGS):' \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e '/ar -rcs/s:ar:$(AR):' \
+ src/Makefile || die
+}
+
+src_compile() {
+ tc-export AR CC
+ emake -C src DEBUG="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ dodir /usr/bin /usr/include /usr/$(get_libdir)
+ emake -C src DESTDIR="${ED}" install
+ dodoc additional_rfcs CHANGES README* RFC959.txt
+ dohtml html/*
+}
diff --git a/net-libs/ftplib/metadata.xml b/net-libs/ftplib/metadata.xml
new file mode 100644
index 000000000000..c572c7d9b478
--- /dev/null
+++ b/net-libs/ftplib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>