summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2023-12-05 11:49:28 +0000
committerSam James <sam@gentoo.org>2023-12-08 11:35:19 +0000
commitf77ae9ecd140086bd66b62ad7d5b03b44a7fddcc (patch)
treec9160be0a62c9a3264248cf07ab0969306fc1371 /net-irc/senpai/senpai-0.3.0.ebuild
parentnet-irc/soju: drop 0.6.1 (diff)
downloadgentoo-f77ae9ecd140086bd66b62ad7d5b03b44a7fddcc.tar.gz
gentoo-f77ae9ecd140086bd66b62ad7d5b03b44a7fddcc.tar.bz2
gentoo-f77ae9ecd140086bd66b62ad7d5b03b44a7fddcc.zip
net-irc/senpai: add 0.3.0
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc/senpai/senpai-0.3.0.ebuild')
-rw-r--r--net-irc/senpai/senpai-0.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/senpai/senpai-0.3.0.ebuild b/net-irc/senpai/senpai-0.3.0.ebuild
new file mode 100644
index 000000000000..d53c9251fc34
--- /dev/null
+++ b/net-irc/senpai/senpai-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Modern terminal IRC client. NOTICE me :senpai!"
+HOMEPAGE="https://sr.ht/~taiite/senpai"
+SRC_URI="https://git.sr.ht/~taiite/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/alfredfo/${PN}-deps/raw/master/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+BDEPEND="
+ app-text/scdoc
+"
+
+src_compile() {
+ ego build ${GOFLAGS} ./cmd/senpai
+
+ scdoc <doc/senpai.1.scd >doc/senpai.1 || die
+ scdoc <doc/senpai.5.scd >doc/senpai.5 || die
+}
+
+src_install() {
+ dobin senpai
+
+ doman doc/senpai.{1,5}
+ einstalldocs
+}