summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/redirbot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/redirbot')
-rw-r--r--net-irc/redirbot/Manifest1
-rw-r--r--net-irc/redirbot/metadata.xml11
-rw-r--r--net-irc/redirbot/redirbot-0.0.5.ebuild25
3 files changed, 37 insertions, 0 deletions
diff --git a/net-irc/redirbot/Manifest b/net-irc/redirbot/Manifest
new file mode 100644
index 000000000000..79dc3774e8cf
--- /dev/null
+++ b/net-irc/redirbot/Manifest
@@ -0,0 +1 @@
+DIST redirbot-0.0.5.tar.gz 4549 SHA256 2e09db06b7c29d3fa03989a3e4177b96fdabf9c25f2a73e2928885f2e96df35d SHA512 7cbd7e8dc792527f26f20ec9953ddafd5fef8dbca457a00198c8bb3e34b660be7e0fadf25d755375e5a40acf64bf4191bf6725a077616a8bdbe120200ec198c7 WHIRLPOOL 3879f9f5411849310241aa846fa8a904862815c52986949da8afe3f979302f4e7e2c16c5bc8d20d2032927291b4bce15a59939715d7cbcb2b8ba6e36bb38ac34
diff --git a/net-irc/redirbot/metadata.xml b/net-irc/redirbot/metadata.xml
new file mode 100644
index 000000000000..96e82ef3a392
--- /dev/null
+++ b/net-irc/redirbot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">redirbot</remote-id>
+ <remote-id type="github">yaccz/redirbot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/redirbot/redirbot-0.0.5.ebuild b/net-irc/redirbot/redirbot-0.0.5.ebuild
new file mode 100644
index 000000000000..56fae74f77d8
--- /dev/null
+++ b/net-irc/redirbot/redirbot-0.0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DOCS=( ChangeLog README.rst )
+
+inherit distutils-r1
+
+DESCRIPTION="IRCBot, telling people they should contact you on different nickname"
+HOMEPAGE="https://github.com/yaccz/redirbot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-11.1.0
+ dev-python/twisted-words
+"
+RDEPEND="${DEPEND}"