summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/emech
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/emech')
-rw-r--r--net-irc/emech/Manifest1
-rw-r--r--net-irc/emech/emech-3.0.3-r1.ebuild87
-rw-r--r--net-irc/emech/metadata.xml5
3 files changed, 93 insertions, 0 deletions
diff --git a/net-irc/emech/Manifest b/net-irc/emech/Manifest
new file mode 100644
index 000000000000..3d860129db77
--- /dev/null
+++ b/net-irc/emech/Manifest
@@ -0,0 +1 @@
+DIST emech-3.0.3.tar.gz 228709 SHA256 e29c62f50206083a9ae8d1f38591c0188a4cb62d09c3aa0f3e71ee3cdf6fb6b2 SHA512 ffe478c0c1800c8afb7afca62dbe08fce6af25a5878ca5fb44bb1271a302d11b96263c51a3848996db8f33f1cdab60d86c26d571d6342fe1505d4dcff83803a3 WHIRLPOOL 82417748e1972e244941a59e508e48510fd7f331239d9114c8b9b814e005881c1659d3ae59ddd7e386eb6ea0a570622eac84c53128babeba49213669616fa141
diff --git a/net-irc/emech/emech-3.0.3-r1.ebuild b/net-irc/emech/emech-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..ab8431593e9f
--- /dev/null
+++ b/net-irc/emech/emech-3.0.3-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo toolchain-funcs
+
+DESCRIPTION="UNIX compatible IRC bot programmed in the C language"
+HOMEPAGE="http://www.energymech.net/"
+SRC_URI="http://www.energymech.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE="debug session tcl"
+
+DOC_CONTENTS="You can find a compressed sample config file at /usr/share/doc/${PF}"
+
+src_prepare() {
+ sed -i \
+ -e 's: "help/":"/usr/share/energymech/help/":' \
+ -e 's: "messages/":"/usr/share/energymech/messages/":' \
+ src/config.h.in || die
+ # Respect CFLAGS and LDFLAGS
+ sed -i \
+ -e '/^LFLAGS/s/\$(PIPEFLAG)/\0 \$(OPTIMIZE) \$(LDFLAGS)/' \
+ -e '/^GDBFLAG/d' \
+ -e '/^PIPEFLAG/d' \
+ src/Makefile.in || die
+
+ epatch_user
+}
+
+myconf() {
+ echo ./configure $*
+ ./configure $* || die "./configure failed"
+}
+
+src_configure() {
+ myconf \
+ --with-alias \
+ --with-botnet \
+ --with-bounce \
+ --with-ctcp \
+ --with-dccfile \
+ --with-dynamode \
+ --with-dyncmd \
+ --with-greet \
+ --with-ircd_ext \
+ --with-md5 \
+ --with-newbie \
+ --with-note \
+ --with-notify \
+ --with-rawdns \
+ --with-redirect \
+ --with-seen \
+ --with-stats \
+ --with-telnet \
+ --with-toybox \
+ --with-trivia \
+ --without-uptime \
+ --with-web \
+ --with-wingate \
+ --without-profiling \
+ $(use_with tcl) \
+ $(use_with session) \
+ $(use_with debug)
+}
+
+src_compile() {
+ emake -C src CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/energymech
+
+ insinto /usr/share/energymech
+ doins -r help
+
+ insinto /usr/share/energymech/messages
+ doins messages/*.txt
+
+ dodoc sample.* README* TODO VERSIONS CREDITS checkmech
+ readme.gentoo_create_doc
+}
diff --git a/net-irc/emech/metadata.xml b/net-irc/emech/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/emech/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>