summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-07-15 00:25:36 +0100
committerSam James <sam@gentoo.org>2021-09-20 04:57:51 +0100
commit138bba575b0816bfd58294e97f84febbed54b13b (patch)
treea9ac3b4a7f1fe3095f40f0523b99bb96c6492c77 /net-im/profanity
parentsys-kernel/zen-sources: version bump 5.14.6 (diff)
downloadgentoo-138bba575b0816bfd58294e97f84febbed54b13b.tar.gz
gentoo-138bba575b0816bfd58294e97f84febbed54b13b.tar.bz2
gentoo-138bba575b0816bfd58294e97f84febbed54b13b.zip
net-im/profanity: Version updated to 0.11.0
* Added dep on virtual/libcrypt. Signed-off-by: Jonathan Davies <jpds@protonmail.com> Bug: https://bugs.gentoo.org/802702 Closes: https://bugs.gentoo.org/789840 Closes: https://github.com/gentoo/gentoo/pull/21647 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.11.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 3bc881c2e234..10964d81786e 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1 +1,2 @@
DIST profanity-0.9.5.tar.gz 830966 BLAKE2B fc1b755b1a92dbde62aacb31cb5d9190cea951e98501a5b48495dbd31266f343cf436de1fa0f69caec34324cd1f781d0bd4f5f7ebdd984324c5d1d6edb91452a SHA512 79305ee488d3a9b87bb422d6525bfaae62c4969d466b968c86941ed5bf0c0080e349758f2e1ead144693513b5d19a635372e73aa1fe9e362836b9245e1d2b898
+DIST profanity-0.11.0.tar.gz 887566 BLAKE2B 373b49670d00aa741e1957a8d3ca0282f6e7215c53c6c89088268d92fa6bd8f396e6c8e69f17aeb65f9183f620376613672c7f71c879ece31b97382df5d7a781 SHA512 14164921e151a9201728afc3835e08649036702d1fcdef6e37f83de6da4b9bd9c5e9ba54db69e3a9e16fb7e360369b4e92b6b771bc5e005e343a9a526738a268
diff --git a/net-im/profanity/profanity-0.11.0.ebuild b/net-im/profanity/profanity-0.11.0.ebuild
new file mode 100644
index 000000000000..1625e5b0c0a8
--- /dev/null
+++ b/net-im/profanity/profanity-0.11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://profanity-im.github.io/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify omemo otr gpg test xscreensaver"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-db/sqlite
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode]
+ virtual/libcrypt:=
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ omemo? (
+ net-libs/libsignal-protocol-c
+ dev-libs/libgcrypt
+ )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-util/cmocka )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable omemo) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}