summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-11-27 10:41:31 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-27 10:59:16 -0500
commit6f6d3540c4559c916269b262f48d91ab6d391b47 (patch)
tree91e378d18924479efcaa96ad5ffae6f59649ed73 /net-ftp
parentnet-dns/dnstop: drop old (diff)
downloadgentoo-6f6d3540c4559c916269b262f48d91ab6d391b47.tar.gz
gentoo-6f6d3540c4559c916269b262f48d91ab6d391b47.tar.bz2
gentoo-6f6d3540c4559c916269b262f48d91ab6d391b47.zip
net-ftp/frox: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/frox/frox-0.7.18-r5.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/net-ftp/frox/frox-0.7.18-r5.ebuild b/net-ftp/frox/frox-0.7.18-r5.ebuild
deleted file mode 100644
index 7bcc20fb9761..000000000000
--- a/net-ftp/frox/frox-0.7.18-r5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils user
-
-DESCRIPTION="A transparent ftp proxy"
-SRC_URI="http://frox.sourceforge.net/download/${P}.tar.bz2"
-HOMEPAGE="http://frox.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-IUSE="clamav ssl transparent"
-
-DEPEND="clamav? ( >=app-antivirus/clamav-0.80 )
- ssl? ( dev-libs/openssl )
- kernel_linux? ( >=sys-kernel/linux-headers-2.6 )"
-RDEPEND="${DEPEND}"
-
-# INSTALL has useful filewall rules
-DOCS=(
- BUGS README
- doc/CREDITS doc/ChangeLog doc/FAQ doc/INSTALL
- doc/INTERNALS doc/README.transdata doc/RELEASE
- doc/SECURITY doc/TODO
-)
-
-pkg_setup() {
- enewgroup ftpproxy
- enewuser ftpproxy -1 -1 /var/spool/frox ftpproxy
-
- use clamav && ewarn "Virus scanner potentialy broken in chroot - see bug #81035"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-respect-CFLAGS.patch"
- epatch "${FILESDIR}/${PV}-netfilter-includes.patch"
- epatch "${FILESDIR}/${P}-config.patch"
-
- if use clamav ; then
- sed -i -e "s:^# VirusScanner.*:# VirusScanner '\"/usr/bin/clamscan\" \"%s\"':" \
- "src/${PN}.conf" || die
- fi
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-http-cache --enable-local-cache \
- --enable-procname \
- --enable-configfile=/etc/frox.conf \
- $(use_enable !kernel_linux libiptc) \
- $(use_enable clamav virus-scan) \
- $(use_enable ssl) \
- $(use_enable transparent transparent-data) \
- $(use_enable !transparent ntp)
-}
-
-src_install() {
- default
-
- keepdir /var/{log,spool}/"${PN}"
-
- fperms 700 /var/spool/frox
- fowners ftpproxy:ftpproxy /var/{log,spool}/frox
-
- dohtml doc/*.html doc/*.sgml
-
- newman "doc/${PN}.man" "${PN}.man.8"
- newman "doc/${PN}.conf.man" "${PN}.conf.man.5"
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
-
- insinto /etc
- newins "src/${PN}.conf" "${PN}.conf.example"
-}