summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/pybootd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/pybootd')
-rw-r--r--net-ftp/pybootd/Manifest1
-rw-r--r--net-ftp/pybootd/files/pybootd-scripts.patch36
-rw-r--r--net-ftp/pybootd/metadata.xml9
-rw-r--r--net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild28
4 files changed, 74 insertions, 0 deletions
diff --git a/net-ftp/pybootd/Manifest b/net-ftp/pybootd/Manifest
new file mode 100644
index 000000000000..37abdb0d1e89
--- /dev/null
+++ b/net-ftp/pybootd/Manifest
@@ -0,0 +1 @@
+DIST pybootd-1.5.0_pre20110524131526.tar.gz 21855 SHA256 55c7f74f32ac160a47631d2ef2f2962c2ea6c3321a3a5ef4dc8aac8be252468d SHA512 113a2195d33ba5a0196810370fedd582204de5f8323ecec37e6209fc7074cde06ba80cb8113fd83be70685c8ea18c6167d751085ea9bee5c1ab34dab152eea71 WHIRLPOOL 967322a33ae6a39f137910af9aa11f58ce58c3e0739817678d071356fa9d2a973411ca56bcdc056c2e0be1b95c410d12ee06dbbeffc960a9bc9125ccfdafdec8
diff --git a/net-ftp/pybootd/files/pybootd-scripts.patch b/net-ftp/pybootd/files/pybootd-scripts.patch
new file mode 100644
index 000000000000..71a001f44798
--- /dev/null
+++ b/net-ftp/pybootd/files/pybootd-scripts.patch
@@ -0,0 +1,36 @@
+install the pybootd.py helper as pybootd otherwise the import gets confused
+
+--- a/setup.py
++++ b/setup.py
+@@ -18,13 +18,23 @@
+ # License along with this library; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
++import shutil
+ from distutils.core import setup
++import distutils.command.install_scripts
+
+
+ def _read(fname):
+ import os
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
++class script_rename(distutils.command.install_scripts.install_scripts):
++
++ def run(self):
++ distutils.command.install_scripts.install_scripts.run(self)
++ for script in self.get_outputs():
++ if script.endswith('.py'):
++ shutil.move(script, script[:-3])
++
+ setup(
+ name='pybootd',
+ version='1.5.0',
+@@ -56,5 +66,7 @@ setup(
+ package_data = {
+ '': ['etc/*.ini', 'etc/*.cfg'],
+ },
++ cmdclass = {'install_scripts': script_rename},
++ scripts = ['pybootd.py'],
+ long_description=_read('README.rst'),
+ )
diff --git a/net-ftp/pybootd/metadata.xml b/net-ftp/pybootd/metadata.xml
new file mode 100644
index 000000000000..e256526db2cd
--- /dev/null
+++ b/net-ftp/pybootd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pybootd</remote-id>
+ <remote-id type="github">eblot/pybootd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild b/net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild
new file mode 100644
index 000000000000..9707b54d22e0
--- /dev/null
+++ b/net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+GIT_HASH="7fd7d045fd4b4cdeebf4d07c1c5cd9649c2172b8"
+
+DESCRIPTION="Simplified BOOTP/DHCP/PXE/TFTP server"
+HOMEPAGE="https://github.com/eblot/pybootd"
+SRC_URI="https://github.com/eblot/pybootd/archive/${GIT_HASH:0:6}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/netifaces-0.5"
+DEPEND=""
+
+S="${WORKDIR}/pybootd-${GIT_HASH}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-scripts.patch
+)