summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/bareftp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/bareftp')
-rw-r--r--net-ftp/bareftp/Manifest2
-rw-r--r--net-ftp/bareftp/bareftp-0.3.10.ebuild33
-rw-r--r--net-ftp/bareftp/bareftp-0.3.9.ebuild33
-rw-r--r--net-ftp/bareftp/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/net-ftp/bareftp/Manifest b/net-ftp/bareftp/Manifest
new file mode 100644
index 000000000000..8123d11c4216
--- /dev/null
+++ b/net-ftp/bareftp/Manifest
@@ -0,0 +1,2 @@
+DIST bareftp-0.3.10.tar.gz 618615 SHA256 d36f10485762d93e38e81618981b540f2130945d7f41c7c0b60b6a0c059cd849 SHA512 944ef7d533b68c772e02e57526b7a4e11afd02a95c4100fcc8902616f1b3b5f14c78df1bba4e67c290a6e2db973dcf979f4a761ac84fc9ca139cc5e49dedf43b WHIRLPOOL 6f3869cbd10405a7a727ab9c3e13e12255118bf877327334c22c3ad9e4208c72766b66fab923207991a0b117b059a2c370691432602b81574073cb279a17bb8c
+DIST bareftp-0.3.9.tar.gz 593672 SHA256 ac799d0b38695c8dbff85ef497746868a4b07ff2a86e61a901d8e61f125aeaef
diff --git a/net-ftp/bareftp/bareftp-0.3.10.ebuild b/net-ftp/bareftp/bareftp-0.3.10.ebuild
new file mode 100644
index 000000000000..5d0632d4c4d0
--- /dev/null
+++ b/net-ftp/bareftp/bareftp-0.3.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit mono gnome2
+
+DESCRIPTION="Mono based file transfer client"
+HOMEPAGE="http://www.bareftp.org/"
+SRC_URI="http://www.bareftp.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gnome-sharp-2.20
+ >=dev-dotnet/gnomevfs-sharp-2.20
+ >=dev-dotnet/gconf-sharp-2.20
+ gnome-keyring? ( >=dev-dotnet/gnome-keyring-sharp-1.0.0-r2 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog CREDITS README"
+ G2CONF="--disable-caches
+ --disable-static
+ $(use_with gnome-keyring gnomekeyring)"
+}
diff --git a/net-ftp/bareftp/bareftp-0.3.9.ebuild b/net-ftp/bareftp/bareftp-0.3.9.ebuild
new file mode 100644
index 000000000000..451ac00b4320
--- /dev/null
+++ b/net-ftp/bareftp/bareftp-0.3.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit mono gnome2
+
+DESCRIPTION="Mono based file transfer client"
+HOMEPAGE="http://www.bareftp.org/"
+SRC_URI="http://www.bareftp.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gnome-keyring"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gnome-sharp-2.20
+ >=dev-dotnet/gnomevfs-sharp-2.20
+ >=dev-dotnet/gconf-sharp-2.20
+ gnome-keyring? ( >=dev-dotnet/gnome-keyring-sharp-1.0.0-r2 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog CREDITS README"
+ G2CONF="--disable-caches
+ --disable-static
+ $(use_with gnome-keyring gnomekeyring)"
+}
diff --git a/net-ftp/bareftp/metadata.xml b/net-ftp/bareftp/metadata.xml
new file mode 100644
index 000000000000..e85974a7fa17
--- /dev/null
+++ b/net-ftp/bareftp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>