summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-08 06:31:15 +0100
committerSam James <sam@gentoo.org>2023-10-08 06:31:15 +0100
commit4ed8f4f1c1a5662225e5c333670266ab038348ac (patch)
treec014f58d18ad716784e367605c52de2c41c23318 /net-fs/netatalk
parentnet-fs/netatalk: add github upstream metadata (diff)
downloadgentoo-4ed8f4f1c1a5662225e5c333670266ab038348ac.tar.gz
gentoo-4ed8f4f1c1a5662225e5c333670266ab038348ac.tar.bz2
gentoo-4ed8f4f1c1a5662225e5c333670266ab038348ac.zip
net-fs/netatalk: add 3.1.18
Bug: https://bugs.gentoo.org/915354 Closes: https://bugs.gentoo.org/915211 Closes: https://bugs.gentoo.org/915212 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs/netatalk')
-rw-r--r--net-fs/netatalk/Manifest1
-rw-r--r--net-fs/netatalk/netatalk-3.1.18.ebuild172
2 files changed, 173 insertions, 0 deletions
diff --git a/net-fs/netatalk/Manifest b/net-fs/netatalk/Manifest
index d7bcf3b126cc..7c5be570f82e 100644
--- a/net-fs/netatalk/Manifest
+++ b/net-fs/netatalk/Manifest
@@ -1,2 +1,3 @@
DIST netatalk-3.1.12.tar.bz2 1918312 BLAKE2B a0672ad769530d96b13a4bf74a1f17d86aa924f05e8185cf6b1bdbfe97fbcf23d36e2f3e5e32a32194a9d3020864e5afa2812f8fb947c68629b15c259a745bf3 SHA512 0b22abaf0084d5684ccc049225abb34caa32893ea8fe7eb67901fde94726f054149ce78d2da49cf06fe30360eb18b2edccff20f9ac69d5ab5105f6d2f4178759
DIST netatalk-3.1.17.tar.xz 975108 BLAKE2B e4bc8bead03f2afbbb2964b1220c029adb10a5d987089aa9f39834c52d90ca72c9894e039a2fecde2b042400aa03f86cfe27589572e834337cbe0877fc21c8a4 SHA512 d63b9b07c1ce316b20980d531240e8e4c71ad164983b2c3127a50d5d1a0e3783acf41120ebf1c9a9da39f5347bd8aa261986dc91bd879979e9defe7c092e8522
+DIST netatalk-3.1.18.tar.xz 974852 BLAKE2B ba69e0bc08455dff46d8aa83fa1a2eda6eac60a0ab7a1b22bba8c47abb57ac70bd2879ec496c5e5f3da40a461e93fcecdf7c3e489daff18e995961f59d4fdc99 SHA512 06c56754afacbf9c71dc2ab7b80c231f5c25f522967e1d825b4e9e129233528bd1e7101144239b52636b9efe7f1f86a37749da8a8af611169155bca9711798d0
diff --git a/net-fs/netatalk/netatalk-3.1.18.ebuild b/net-fs/netatalk/netatalk-3.1.18.ebuild
new file mode 100644
index 000000000000..0a3e76e016b5
--- /dev/null
+++ b/net-fs/netatalk/netatalk-3.1.18.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic pam systemd
+
+DESCRIPTION="Open Source AFP server"
+HOMEPAGE="https://netatalk.sourceforge.net/"
+SRC_URI="https://github.com/Netatalk/netatalk/releases/download/netatalk-${PV//./-}/netatalk-${PV}.tar.xz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0/18.0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="acl cracklib dbus debug kerberos ldap pam pgp quota +shadow ssl tracker tcpd zeroconf"
+
+RDEPEND="
+ !app-editors/yudit
+ dev-libs/libevent:=
+ >=dev-libs/libgcrypt-1.2.3:=
+ sys-apps/coreutils
+ >=sys-libs/db-4.2.52:=
+ sys-libs/tdb
+ virtual/libcrypt:=
+ acl? (
+ sys-apps/attr
+ sys-apps/acl
+ )
+ cracklib? ( sys-libs/cracklib )
+ dbus? ( sys-apps/dbus dev-libs/dbus-glib )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap:= )
+ pam? ( sys-libs/pam )
+ ssl? ( dev-libs/openssl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ tracker? ( app-misc/tracker:3= )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
+ sys-devel/flex
+"
+
+RESTRICT="test"
+
+REQUIRED_USE="
+ ldap? ( acl )
+ tracker? ( dbus )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.17-gentoo.patch
+ "${FILESDIR}"/${PN}-3.1.17-disable-ld-library-path.patch # bug #564350
+)
+
+src_prepare() {
+ default
+ append-flags -fno-strict-aliasing
+
+ sed \
+ -e "s:shell_utils::g" \
+ -i contrib/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=()
+
+ # Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # TODO:
+ # * systemd: --with-init-style=systemd
+ myeconfargs+=(
+ $(use_enable debug)
+ $(use_enable debug debugging)
+ $(use_enable pgp pgp-uam)
+ $(use_enable kerberos krbV-uam)
+ $(use_enable quota)
+ $(use_enable tcpd tcp-wrappers)
+ $(use_enable zeroconf)
+ $(use_with acl acls)
+ $(use_with cracklib)
+ $(use_with dbus afpstats)
+ $(use_with kerberos)
+ $(use_with ldap)
+ $(use_with pam)
+ $(use_with shadow)
+ $(use_with ssl ssl-dir)
+ $(use_with tracker dbus-daemon "${EPREFIX}/usr/bin/dbus-daemon")
+ $(use_with tracker tracker-pkgconfig-version $(ver_cut 1 $(best_version app-misc/tracker | sed 's:app-misc/tracker-::g')).0)
+ --disable-static
+ --enable-overwrite
+ --disable-afs
+ --with-bdb=/usr
+ --with-uams-path=/usr/$(get_libdir)/${PN}
+ --with-init-style=gentoo-openrc
+ --without-tdb
+ --with-lockfile=/run/lock/${PN}
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use zeroconf; then
+ sed -i -e '/avahi-daemon/s:use:need:g' "${ED}"/etc/init.d/${PN} || die
+ else
+ sed -i -e '/avahi-daemon/d' "${ED}"/etc/init.d/${PN} || die
+ fi
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${ED}/etc/pam.d" || die
+
+ if use pam; then
+ pamd_mimic_system netatalk auth account password session
+ fi
+
+ sed \
+ -e "s|:SBINDIR:|${EPREFIX}/usr/sbin|g" \
+ -e "s|:PATH_NETATALK_LOCK:|/run/lock/netatalk|g" \
+ distrib/initscripts/service.systemd.tmpl \
+ > "${T}"/service.systemd || die
+ systemd_newunit "${T}"/service.systemd ${PN}.service
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ local fle v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_test ${v} -lt 3) ]]; then
+ for fle in afp_signature.conf afp_voluuid.conf; do
+ if [[ -f "${ROOT}"/etc/netatalk/${fle} ]]; then
+ if [[ ! -f "${ROOT}"/var/lib/netatalk/${fle} ]]; then
+ mv \
+ "${ROOT}"/etc/netatalk/${fle} \
+ "${ROOT}"/var/lib/netatalk/
+ fi
+ fi
+ done
+
+ elog
+ elog "Starting from version 3.0 only uses a single init script again"
+ elog "Please update your runlevels accordingly"
+ elog
+ elog "Dependencies should be resolved automatically depending on settings"
+ elog "but please report issues with this on https://bugs.gentoo.org/ if"
+ elog "you find any."
+ elog
+ elog "Following config files are obsolete now:"
+ elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
+ elog "in favour of"
+ elog "/etc/afp.conf"
+ elog
+ elog "Please convert your existing configs before you restart your daemon"
+ elog
+ elog "The new AppleDouble default backend is appledouble = ea"
+ elog "Existing entries will be updated on access, but can do an offline"
+ elog "conversion with"
+ elog "dbd -ruve /path/to/Volume"
+ elog
+ elog "For general notes on the upgrade, please visit"
+ elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
+ elog
+ break
+ fi
+ done
+}