summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-04-14 23:24:18 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-22 21:21:45 +0200
commit37eac0d217676a67d04e534331b9d7fba020df86 (patch)
tree32ea16873fbe6833b70437c67d8145790b9a9ffa /net-dns
parentmail-mta/exim-4.90.1: hppa stable, bug 647240 (diff)
downloadgentoo-37eac0d217676a67d04e534331b9d7fba020df86.tar.gz
gentoo-37eac0d217676a67d04e534331b9d7fba020df86.tar.bz2
gentoo-37eac0d217676a67d04e534331b9d7fba020df86.zip
net-dns/knot: bump to 2.6.6
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-2.6.6.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 2eb1fc35e4cc..89c6c2cdc764 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,2 +1,3 @@
DIST knot-2.5.7.tar.xz 1084656 BLAKE2B c2d583625a19f6a61248b3b42cdf14f5bb2bdbafdb20be6b0813744095a4016a4be2eb5e2dfaff0628238c60153480175a86706db0b88569d76156f86ba33968 SHA512 96e375f556309bb89cea982dda169cef70c23d03c48282110e47a44849c1102cd37d98aa7650781b399f5d932b724b8a935f0b9e55e4920465ae7b74a0d1d55a
DIST knot-2.6.5.tar.xz 1118084 BLAKE2B 941d90803e51c5af003fcdaaaa22ffede326492cf60836efc09a06e18740743cc9f806e4750934f6959ced88616f46fc5dbc6667099d53eb4a21fae524497c9c SHA512 ed0d1d30e6d8d802e669aac12c4fd0cec8e315eb0e2c05b722f49ada434c82b8caebf12568881e5fbba2f61a5027c44fbde42b543c9086ff2e9614caf42a6d12
+DIST knot-2.6.6.tar.xz 1120340 BLAKE2B 374d9b78f2ef2143d1221fced29184a52ee3773abd7cb08b6b48910f6ffc0f7c4f07c00d17d28344c93d71a709363bdf855d20587f87da622153c44d08d85fd8 SHA512 bd7a36decc74041f12971045cd69b8cc9e7ecce68f8d2b4cddc9b5f23ee96e8ed290d98fe9e6c441d6727ad4395bea615cbd9ec19cc641abce19ef8da6371972
diff --git a/net-dns/knot/knot-2.6.6.ebuild b/net-dns/knot/knot-2.6.6.ebuild
new file mode 100644
index 000000000000..2c624d4be58a
--- /dev/null
+++ b/net-dns/knot/knot-2.6.6.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu
+ dev-python/lmdb
+ net-libs/gnutls
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? (
+ !libidn2? ( net-dns/libidn )
+ libidn2? ( net-dns/libidn2 )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}