summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-04-01 11:33:05 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-04-01 11:34:01 +0200
commit85c7553de73434c9a9ff972c9b16a67f283e78fb (patch)
tree9d2c549b7ed7868a8b009f3b35a0f217e4df23f4 /net-dialup
parentsys-kernel/vanilla-sources: Automated version bump to {5.4.29,5.5.14,5.6.1} -... (diff)
downloadgentoo-85c7553de73434c9a9ff972c9b16a67f283e78fb.tar.gz
gentoo-85c7553de73434c9a9ff972c9b16a67f283e78fb.tar.bz2
gentoo-85c7553de73434c9a9ff972c9b16a67f283e78fb.zip
net-dialup/xl2tpd-1.3.15: version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xl2tpd/Manifest1
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/Manifest b/net-dialup/xl2tpd/Manifest
index efd75effbd72..c7005a312290 100644
--- a/net-dialup/xl2tpd/Manifest
+++ b/net-dialup/xl2tpd/Manifest
@@ -2,3 +2,4 @@ DIST xl2tpd-1.3.10.tar.gz 510777 BLAKE2B 15ec09a6186d20facd4eceeca87a33a4676644a
DIST xl2tpd-1.3.11.tar.gz 510652 BLAKE2B c120ba0a2bb96a87334743319808e4a1dfb1b95140fc37df51c33e176bdefdac547ad27d38731bab9d94a939b9a3ca93404ef17c8076e16567a3ecc5b568fb47 SHA512 9fd478aa6b7e22867aa977aa0c22ba9d856e3b659aa0ffdcdb17aa0d8358cceab37da565eeb799590d65fc2914720715423e006f6bbe7ca742f09d7cced52cb7
DIST xl2tpd-1.3.12.tar.gz 513173 BLAKE2B a1f2e4d0e1af4402679eeec6589ca17b0422c664d37beae628511f988f6508ca22160d4657f8ff84bc5e5aac4d3e837c501b4d307964530044a792f2ecc599ab SHA512 e18f15ba038cd358fbad9dd7284c5f3c34273d9291bf8c66494c46d78150acfc1666cbf935fb5a66bd1f0220014f0b49fa0f7f55cb42de125e4123112c6eb00b
DIST xl2tpd-1.3.13.tar.gz 513958 BLAKE2B 66c2bcbb54191445f1a519d507b2ec67b48d9e994db09b8c6fc9980b03bf5aab09a2f6187170f0e8639bd8a323b8417bf6e5d0a80fd9e45f8adc310902b256ae SHA512 02e3502a75f41745c001fe1a34dd9900c3a77eea274e08f9361f7145ac24e9a663975efe85ef6aef7c6da1aa9f3369eeb5542ac26e90b9d59753158a17b69ee4
+DIST xl2tpd-1.3.15.tar.gz 524960 BLAKE2B 5349b4bce7e4b8ea26ec3c739847456b6c8fdac667c8ad9d5241d3c83bc450a47c88c99c37cea2b0461fd4abb3e32da67de7c8ab95d288c8c423bea9af4abf1d SHA512 f65c7f2f1c03728d825b8857baa0c2297e9d5dbd97a2375484a32851326db5951deb9bf3598cbec860f0787d1bb577b4f0a47372e3244fd92c8bad7ce684889b
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild
new file mode 100644
index 000000000000..a0c41af7ca21
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="https://github.com/xelerance/xl2tpd"
+SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+kernel"
+
+DEPEND="
+ net-libs/libpcap
+ >=sys-kernel/linux-headers-2.6"
+
+RDEPEND="
+ ${DEPEND}
+ net-dialup/ppp"
+
+DOCS=(CREDITS README.md BUGS CHANGES TODO doc/README.patents)
+
+src_compile() {
+ tc-export CC
+ local OSFLAGS="-DLINUX"
+ use kernel && OSFLAGS+=" -DUSE_KERNEL"
+ emake OSFLAGS="$OSFLAGS"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+
+ systemd_dounit "${FILESDIR}"/xl2tpd.service
+ systemd_dotmpfilesd "${FILESDIR}"/xl2tpd.conf
+
+ einstalldocs
+
+ insinto /etc/xl2tpd
+ newins doc/l2tpd.conf.sample xl2tpd.conf
+ insopts -m 0600
+ newins doc/l2tp-secrets.sample l2tp-secrets
+}