summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-12 20:51:16 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-12 20:51:16 +0100
commit86d9feeb49088b883fd3a7d128c342658d6d6ead (patch)
treefcc0db0c95f8d23514ce3427278fe0e0568c4e68 /net-analyzer
parentnet-misc/openssh: Revision bump, update X509 patch to 11.2 (diff)
downloadgentoo-86d9feeb49088b883fd3a7d128c342658d6d6ead.tar.gz
gentoo-86d9feeb49088b883fd3a7d128c342658d6d6ead.tar.bz2
gentoo-86d9feeb49088b883fd3a7d128c342658d6d6ead.zip
net-analyzer/tcpreplay: Version 4.3.0_beta1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.0_beta1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index a5a7e79becdd..34fe3f97958d 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,2 +1,3 @@
DIST tcpreplay-4.1.2.tar.gz 2162175 BLAKE2B a99542277084a419c1f1208392e3d5b47aaf0be61a8e8de33bee9ba8e4f636fa78ae8eabcc07031c9bb659a8ba58a0aad6e4cc102e56d3dbddb0c3cf11c9df51 SHA512 3a7d125f38fe15070d666eacb4a5ef026a73ff850adec7ef3592966f38d1d155002792c5d5ac2476aa034d71be5f31b9dacd5be34af01a336149af3a42cad360
DIST tcpreplay-4.2.6.tar.gz 3494827 BLAKE2B 57222d7347efd780d2e1297145a7d81c8cce58a8d43bdb9b1485ef2514751e61af317dc4f5ff2068c214b2a33115d8099204d4b3165671d87bd8549c2df08bbd SHA512 a46846b29e3cd7fbc635faee9c4be90db0d346c0d0f291ac8e007e1fbf614289094e14480c1c5b40feb5a175d3cbad018e2dd4d1a5762b7d31a4325af6102e7e
+DIST tcpreplay-4.3.0_beta1.tar.xz 719884 BLAKE2B 872ea10a3986f122cbf48bf9217d8df96f8c8c08e37aee095fc92ab5d5cf2607b42327aab9de5453c8bd198e1a32a3ae8964b085ba3065a6b3adfd853dd0b43b SHA512 55a9c419d4604cb4912571a631035ad4bc70d06b44d0248629a47b76411c23cba63b824322c23e0f2eeac4131a5d6e4c1fb2b9a60c0f57a7397d46760ff818f9
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.0_beta1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.0_beta1.ebuild
new file mode 100644
index 000000000000..24946408748e
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.0_beta1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+LICENSE="BSD GPL-3"
+SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+DEPEND="
+ >=sys-devel/autogen-5.18.4[libopts]
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ tcpdump? ( net-analyzer/tcpdump )
+ pcapnav? ( net-libs/libpcapnav )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ docs/{CHANGELOG,CREDIT,HACKING,TODO}
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.0-enable-pcap_findalldevs.patch
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug 252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ --disable-local-libopts \
+ --enable-dynamic-link \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]]; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}