summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-08 19:53:43 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-08 19:53:43 +0100
commit11e1cbaaa223361e5ef8a95ea5f685cfd9107552 (patch)
tree2f33f47f83b0493dfba257a3e4bb876e44dde399 /net-analyzer
parentdev-util/promu: Add new snapshot (diff)
downloadgentoo-11e1cbaaa223361e5ef8a95ea5f685cfd9107552.tar.gz
gentoo-11e1cbaaa223361e5ef8a95ea5f685cfd9107552.tar.bz2
gentoo-11e1cbaaa223361e5ef8a95ea5f685cfd9107552.zip
net-analyzer/prometheus: Version bump to 2.2.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.2.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index ce06a9eb774e..288c83a6b607 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1 +1,2 @@
DIST prometheus-2.1.0.tar.gz 5669858 BLAKE2B 96b9d7b1eb13017806cb2745cb874468a419550c7372aa8abada9d1a4e7fe386785f05abe8fd5681745db4a0c17260d5fde704a3b3ac5807107da0a935177264 SHA512 8adbbfcf6cf5b0bdd4a96f51f6c179c828d75a231b35f9ef40db6c07bcb8ffa6a3eb969b55a52ac70528ad5c8fe486be866db6ae174006220e0cfaa1da624346
+DIST prometheus-2.2.0.tar.gz 5629498 BLAKE2B 6d48a58258e47fe35201581fa11070b1951b633768895ce810448d13d8184072b85160510d355b06a2d09bf0c9a5785c29f0ac062fe0472b29a4c94b74ccd7cc SHA512 680ae3cb653452f1506bc62cf909994bd142ee53c9f6520391786967cfd09bd96c774fbacc09e1c9c06ebf759899a45fd0040fe7eef53c1256df390a41dcc8bf
diff --git a/net-analyzer/prometheus/prometheus-2.2.0.ebuild b/net-analyzer/prometheus/prometheus-2.2.0.ebuild
new file mode 100644
index 000000000000..7c4a1eb8c4e1
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="f63e7db"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}