summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-29 21:51:31 +0100
committerSam James <sam@gentoo.org>2022-05-16 05:17:45 +0000
commitede1ced544c48c380337cf212f0d04d840def1d3 (patch)
treed34362eb3f0f24243d58a76988f2baf37f582a3b /net-analyzer/termshark
parentsys-auth/polkit: restore polkit-0.118-make-netgroup-support-optional.patch (diff)
downloadgentoo-ede1ced544c48c380337cf212f0d04d840def1d3.tar.gz
gentoo-ede1ced544c48c380337cf212f0d04d840def1d3.tar.bz2
gentoo-ede1ced544c48c380337cf212f0d04d840def1d3.zip
net-analyzer/termshark: new ebuild
(sam: modified to use dep tarball) Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/24019 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/termshark')
-rw-r--r--net-analyzer/termshark/Manifest2
-rw-r--r--net-analyzer/termshark/metadata.xml15
-rw-r--r--net-analyzer/termshark/termshark-2.3.0.ebuild38
3 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/termshark/Manifest b/net-analyzer/termshark/Manifest
new file mode 100644
index 000000000000..fe40fed940d0
--- /dev/null
+++ b/net-analyzer/termshark/Manifest
@@ -0,0 +1,2 @@
+DIST termshark-2.3.0-deps.tar.xz 142126384 BLAKE2B 3693a5b5470c338a510aa964059e001f3f4d68a3f824191bb7debefa61976e30d10c77ce5e7ef68836732c7a317e2d9a20c170b3a4565b456c130b9b8999a16a SHA512 ccf3576bba18cf429610deea7c69479fae06368d12e584fd9bd0e3d7409069d6994fa3ecc27fe84f38bcc2606018587de1bf28cde103e9477e39351c94dd2c31
+DIST termshark-2.3.0.tar.gz 382710 BLAKE2B 7c2953188829d950bc005cc2b9d568ece6fdc636c1bdf2e6d29c03af5358894238aff072848e51e8298e317c6b5467c6e1a6823c1abd5a432c819ca44d5f4f9a SHA512 0ed780ec1ba86d2a6eb11c940f00475c750075d5e1ae4a6022f465572717126df941e933e2db7123d802b721f8e1187014f02d4c5dfd84c1a55009045dce5a88
diff --git a/net-analyzer/termshark/metadata.xml b/net-analyzer/termshark/metadata.xml
new file mode 100644
index 000000000000..09186a431868
--- /dev/null
+++ b/net-analyzer/termshark/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gcla/termshark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/termshark/termshark-2.3.0.ebuild b/net-analyzer/termshark/termshark-2.3.0.ebuild
new file mode 100644
index 000000000000..4d036b919eed
--- /dev/null
+++ b/net-analyzer/termshark/termshark-2.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A terminal UI for tshark, inspired by Wireshark"
+HOMEPAGE="https://termshark.io/"
+SRC_URI="https://github.com/gcla/termshark/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+# termshark doesn't link against wireshark. It reads data via IPC during
+# runtime.
+RDEPEND="
+ net-analyzer/wireshark[dumpcap,pcap,tshark]
+"
+
+src_compile() {
+ ego build ./...
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ GOBIN="${S}/bin" ego install ./...
+
+ dobin bin/${PN}
+ dodoc README.md
+ dodoc docs/*
+}