summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-20 05:59:54 +0100
committerSam James <sam@gentoo.org>2023-04-20 06:01:06 +0100
commitca0a64851bba7ed7e7b2ed8b9aabda6bf1703e73 (patch)
treea6d4305c35df33817cb6988be19ae9a91f1d89ff /net-analyzer/sngrep
parentnet-fs/nfs-utils: add 2.6.3 (diff)
downloadgentoo-ca0a64851bba7ed7e7b2ed8b9aabda6bf1703e73.tar.gz
gentoo-ca0a64851bba7ed7e7b2ed8b9aabda6bf1703e73.tar.bz2
gentoo-ca0a64851bba7ed7e7b2ed8b9aabda6bf1703e73.zip
net-analyzer/sngrep: add 1.7.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/sngrep')
-rw-r--r--net-analyzer/sngrep/Manifest1
-rw-r--r--net-analyzer/sngrep/sngrep-1.7.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/Manifest b/net-analyzer/sngrep/Manifest
index 8a4dffff00ae..f8a03b85593f 100644
--- a/net-analyzer/sngrep/Manifest
+++ b/net-analyzer/sngrep/Manifest
@@ -1 +1,2 @@
DIST sngrep-1.6.0.tar.gz 248091 BLAKE2B a08c50d87d43f49f24494a85b8f4d72f24a649050ab696cabd087a39bd64532a9e7ed137ccaacecddce8ef22c960fc43f5372c9b13817eae26dd06b711363e3b SHA512 bca3192e1aacf4152f566925fd075dfd957cbe87017c8258303c8689f1221ea082f337866db45cb5ada0629f7cc4b66ce73b74a911d230c63d10fefa19aaebe3
+DIST sngrep-1.7.0.tar.gz 248947 BLAKE2B 39a5d9bc71df9fb5bd4abadadf3f8fc8a680dd06eb4a7f06bb597a70215854d0ee4b93b39cfff67e2b15b6fed4ffac2865741af31b21a7ba8a91f9c01c4c750a SHA512 ecf31d61643ecc9ba1a9fe7759ae8c2c65fcbf6886ed263def2993dd6900eb9aeaddce8ebbde71e1ec57fbdc11a388de05f7c13f4587714e3b3e33689cf591b0
diff --git a/net-analyzer/sngrep/sngrep-1.7.0.ebuild b/net-analyzer/sngrep/sngrep-1.7.0.ebuild
new file mode 100644
index 000000000000..4ec90e3677e8
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="https://github.com/irontec/sngrep/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eep gnutls pcre ssl zlib"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:=[unicode(+)]
+ ssl? (
+ !gnutls? ( dev-libs/openssl:= )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ pcre? ( dev-libs/libpcre2 )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-ipv6
+ --enable-unicode
+ --without-pcre
+ $(use_enable eep)
+ $(use_with pcre pcre2)
+ $(use_with ssl $(usex gnutls gnutls openssl))
+ $(use_with zlib)
+ )
+
+ econf "${myeconfargs[@]}"
+}