summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ncrack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ncrack')
-rw-r--r--net-analyzer/ncrack/Manifest2
-rw-r--r--net-analyzer/ncrack/metadata.xml14
-rw-r--r--net-analyzer/ncrack/ncrack-0.3_alpha.ebuild33
-rw-r--r--net-analyzer/ncrack/ncrack-0.4_alpha.ebuild40
4 files changed, 89 insertions, 0 deletions
diff --git a/net-analyzer/ncrack/Manifest b/net-analyzer/ncrack/Manifest
new file mode 100644
index 000000000000..3d6dd9e6661a
--- /dev/null
+++ b/net-analyzer/ncrack/Manifest
@@ -0,0 +1,2 @@
+DIST ncrack-0.3ALPHA.tar.gz 4430878 RMD160 5c48006cb346b68f067cdc54bbff410e4a0ba465 SHA1 89b3fa98c9f85d8f23d638a89c53259a7b7ae82d SHA256 e9293f772ebb57c482ac83c57e76fa08b00df216c16987822cdf007928e21168
+DIST ncrack-0.4ALPHA.tar.gz 2208130 RMD160 1ab6b88e26e223f39cbf1e49a612fae572289aa8 SHA1 954ff0f5ed8850490c7b0e7f89dce3876791bf3b SHA256 f8bd7e0ef68559490064ec0a5f139b2b9c49aeaf9f6323e080db9ff344c87603
diff --git a/net-analyzer/ncrack/metadata.xml b/net-analyzer/ncrack/metadata.xml
new file mode 100644
index 000000000000..77d8e7551191
--- /dev/null
+++ b/net-analyzer/ncrack/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+<flag name="ssh">Compile and link against the internal openssh modified library.</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-analyzer/ncrack/ncrack-0.3_alpha.ebuild b/net-analyzer/ncrack/ncrack-0.3_alpha.ebuild
new file mode 100644
index 000000000000..31d3db9dbacd
--- /dev/null
+++ b/net-analyzer/ncrack/ncrack-0.3_alpha.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit base versionator
+
+MY_P="${PN}-$(get_version_component_range 1-2)ALPHA"
+
+DESCRIPTION="a high-speed network authentication cracking tool"
+HOMEPAGE="http://nmap.org/ncrack/"
+SRC_URI="http://nmap.org/${PN}/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/STRIP =/s:= .*:= echo:' Makefile.in || die
+}
+
+src_configure() {
+ econf --with-openssl=$(use ssl && echo yes || echo no)
+}
+
+DOCS=( CHANGELOG docs/{AUTHORS,TODO,{engine,mirror_pool,openssh-library}.txt} )
diff --git a/net-analyzer/ncrack/ncrack-0.4_alpha.ebuild b/net-analyzer/ncrack/ncrack-0.4_alpha.ebuild
new file mode 100644
index 000000000000..028c18d94bab
--- /dev/null
+++ b/net-analyzer/ncrack/ncrack-0.4_alpha.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit base versionator
+
+MY_P="${PN}-$(get_version_component_range 1-2)ALPHA"
+
+DESCRIPTION="a high-speed network authentication cracking tool"
+HOMEPAGE="http://nmap.org/ncrack/"
+SRC_URI="http://nmap.org/${PN}/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssh ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ ssh? ( net-misc/openssh )"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG docs/{AUTHORS,TODO,{devguide,mirror_pool,ncrack\.usage,openssh-library}.txt} )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/STRIP =/s:= .*:= echo:' Makefile.in || die
+}
+
+src_configure() {
+ econf --with-openssl=$(use ssl && echo yes || echo no) \
+ --with-openssh=$(use ssh && echo yes || echo no)
+}
+
+src_install() {
+ base_src_install
+ doman docs/${PN}.1 || die "doman failed"
+}