summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagios-check_fail2ban
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagios-check_fail2ban')
-rw-r--r--net-analyzer/nagios-check_fail2ban/Manifest1
-rw-r--r--net-analyzer/nagios-check_fail2ban/metadata.xml18
-rw-r--r--net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_fail2ban/Manifest b/net-analyzer/nagios-check_fail2ban/Manifest
new file mode 100644
index 000000000000..565e94891118
--- /dev/null
+++ b/net-analyzer/nagios-check_fail2ban/Manifest
@@ -0,0 +1 @@
+DIST nagios-check_fail2ban-3.tar.gz 1848 SHA256 8aa2f8d2cdd687d98906f963b68d5c711471caf626d7be7741461bfd4b83af78 SHA512 a032042f8588575ef70c6644c5d385a18b25b89d71b067cdfe78230e5e53c2fb5bf88de1d97aa9411bfec00b213f6e1eae800e9545f0d8d4bad4e3c878927f9c WHIRLPOOL a9c328633cee90c753aefa4dd24810803f9e308c9833929009409deaf0c448927d74c310b923fa0ca152cf00fc87217500fe3f7ddbbabb82c2984af6df061895
diff --git a/net-analyzer/nagios-check_fail2ban/metadata.xml b/net-analyzer/nagios-check_fail2ban/metadata.xml
new file mode 100644
index 000000000000..87a73df9a44f
--- /dev/null
+++ b/net-analyzer/nagios-check_fail2ban/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>andrew@ahamilto.net</email>
+ <name>Andrew Hamilton</name>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>sdamashek@gentoo.org</email>
+ <name>Samuel Damashek</name>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <upstream>
+ <remote-id type="github">hollow/check_fail2ban</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild b/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild
new file mode 100644
index 000000000000..33dc889474b7
--- /dev/null
+++ b/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib autotools
+
+GITHUB_AUTHOR="hollow"
+GITHUB_PROJECT="check_fail2ban"
+GITHUB_COMMIT="c554837"
+
+DESCRIPTION="A nagios plugin for checking the fail2ban daemon"
+HOMEPAGE="https://github.com/hollow/check_fail2ban"
+SRC_URI="http://nodeload.github.com/${GITHUB_AUTHOR}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-analyzer/nagios-plugins-1.4.13-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${GITHUB_AUTHOR}-${GITHUB_PROJECT}-${GITHUB_COMMIT}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}