summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 13:41:33 +0100
committerSam James <sam@gentoo.org>2023-05-01 13:48:50 +0100
commitb35bb8789100212b97876c1fbcde390c1fa82be4 (patch)
treedd2ade79a0b809434ad59fca7a077faa73c835d0 /net-analyzer/linkchecker
parentnet-analyzer/knocker: drop 0.7.1-r3 (diff)
downloadgentoo-b35bb8789100212b97876c1fbcde390c1fa82be4.tar.gz
gentoo-b35bb8789100212b97876c1fbcde390c1fa82be4.tar.bz2
gentoo-b35bb8789100212b97876c1fbcde390c1fa82be4.zip
net-analyzer/linkchecker: drop 10.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/Manifest1
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch32
-rw-r--r--net-analyzer/linkchecker/linkchecker-10.1.0.ebuild59
3 files changed, 0 insertions, 92 deletions
diff --git a/net-analyzer/linkchecker/Manifest b/net-analyzer/linkchecker/Manifest
index a575a4184c68..df363ab6f476 100644
--- a/net-analyzer/linkchecker/Manifest
+++ b/net-analyzer/linkchecker/Manifest
@@ -1,2 +1 @@
DIST LinkChecker-10.2.1.tar.gz 545530 BLAKE2B ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549 SHA512 6410aff11e94cbf001979a85dd41e50daaa6a3577689d4256a0a5627a29253baef24ed7739dbafe91f58c0841923ac3094aa558e91f34629e3e6c008e461230a
-DIST linkchecker-10.1.0.tar.gz 521214 BLAKE2B 767c1176751a2011e0e175eb7c9e7b3704bda0d469bad7b38ac1481db62b470fbb69a62bf11316699e15fd1ca822f801a1237c798754353aba5c559ccd9d3274 SHA512 a6ba57ef9c617ece2c53d54cf460571561bfa60831e038e31e520e7fbee789566616b6e5b0b98529376510ef4e228bebdb6e6e011fb986b74d837ebc69323085
diff --git a/net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch b/net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch
deleted file mode 100644
index f0132a8a8089..000000000000
--- a/net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/setup.py b/setup.py
-index c00bdc0..8493d09 100755
---- a/setup.py
-+++ b/setup.py
-@@ -56,6 +56,7 @@ else:
-
- # the application name
- AppName = "LinkChecker"
-+AppVersion = "LINKCHECKER_VERSION"
- Description = "check links in web documents or full websites"
-
- RELEASE_DATE_FILE = "_release_date"
-@@ -340,10 +341,7 @@ if os.name == "posix":
-
- setup(
- name=AppName,
-- use_scm_version={
-- "local_scheme": "node-and-timestamp",
-- "version_scheme": "post-release",
-- },
-+ version=AppVersion,
- description=Description,
- keywords="link,url,site,checking,crawling,verification,validation",
- author=myname,
-@@ -383,7 +381,6 @@ setup(
- options={},
- # Requirements, usable with setuptools or the new Python packaging module.
- python_requires=">= 3.6",
-- setup_requires=["setuptools_scm"],
- install_requires=[
- "importlib_metadata;python_version<'3.8'",
- "requests >= 2.4",
diff --git a/net-analyzer/linkchecker/linkchecker-10.1.0.ebuild b/net-analyzer/linkchecker/linkchecker-10.1.0.ebuild
deleted file mode 100644
index 228488bd17f2..000000000000
--- a/net-analyzer/linkchecker/linkchecker-10.1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-PYTHON_REQ_USE="sqlite?"
-
-inherit bash-completion-r1 distutils-r1 optfeature
-
-DESCRIPTION="Check websites for broken links"
-HOMEPAGE="https://github.com/linkcheck/linkchecker"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/linkchecker/linkchecker/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="sqlite"
-# requires libs not present in portage yet
-RESTRICT="test"
-
-RDEPEND="
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-9.3-bash-completion.patch"
- "${FILESDIR}/${PN}-10.1.0-version.patch"
-)
-
-DOCS=(
- doc/changelog.txt
- doc/upgrading.txt
-)
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- sed -e "s/LINKCHECKER_VERSION/${PV}/g" -i setup.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newbashcomp config/linkchecker-completion ${PN}
-}
-
-pkg_postinst() {
- optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
- optfeature "Virus scanning" app-antivirus/clamav
- optfeature "GNOME proxy settings support" dev-python/pygobject[${PYTHON_USEDEP}]
-}