summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/argus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/argus')
-rw-r--r--net-analyzer/argus/Manifest2
-rw-r--r--net-analyzer/argus/argus-3.0.8.1.ebuild79
-rw-r--r--net-analyzer/argus/argus-3.0.8.ebuild79
-rw-r--r--net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch22
-rw-r--r--net-analyzer/argus/files/argus-3.0.5-Makefile.patch20
-rw-r--r--net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch17
-rw-r--r--net-analyzer/argus/files/argus-3.0.8.1-disable-tcp-wrappers-automagic.patch22
-rw-r--r--net-analyzer/argus/files/argus.initd20
-rw-r--r--net-analyzer/argus/metadata.xml6
9 files changed, 267 insertions, 0 deletions
diff --git a/net-analyzer/argus/Manifest b/net-analyzer/argus/Manifest
new file mode 100644
index 000000000000..de07ceb29069
--- /dev/null
+++ b/net-analyzer/argus/Manifest
@@ -0,0 +1,2 @@
+DIST argus-3.0.8.1.tar.gz 523375 SHA256 1fb921104c8bd843fb9f5a1c32b57b20bfe8cd8a103b3f1d9bb686b9e6c490a4 SHA512 d96332849df7ce2297aa0d81a9f22c12763d04b2936ffaffc0e4b1942535846cfbc41dadf28791eb88d1ffd0429bdc280d16dff44369c415c713064849b158f7 WHIRLPOOL 2c9495d585c2297b3f9951e74a8fd28840941be6b298c0178d44801242d1abda4bd08f9469e2dd1a4b802735611c9ff82bc028d838628b1ccb184ba80d5dc529
+DIST argus-3.0.8.tar.gz 1193140 SHA256 335d889d288763487ad3545c09b944d7d6aa2538630d1fd72eea3704a57bf6e3 SHA512 e4211bb09f442f4dc5c210b878d0f5a9527ff9c95030570e20520f2ca5c3053cc603aa3f0c4aad33363fee6ce02c3d5262bbfdecd2e2157dc00a34f333f14232 WHIRLPOOL 0a07f7f2e57bf7082af0d1ec203463cf0bedf0b682db89ae484e2162bb79f24b084a7c3d30da447d998885458444bc3799bb401c86e1a2b2dc6a7643127da0c9
diff --git a/net-analyzer/argus/argus-3.0.8.1.ebuild b/net-analyzer/argus/argus-3.0.8.1.ebuild
new file mode 100644
index 000000000000..9a99e1488bbf
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.8.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils user
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug sasl tcpd"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib
+ sasl? ( dev-libs/cyrus-sasl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.8.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch \
+ "${FILESDIR}"/${PN}-3.0.7.3-DLT_IPNET.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers) $(use_with sasl)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/*.5 man/man8/*.8
+
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ keepdir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that the init script will fail to work."
+}
diff --git a/net-analyzer/argus/argus-3.0.8.ebuild b/net-analyzer/argus/argus-3.0.8.ebuild
new file mode 100644
index 000000000000..1010dcf1d591
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils user
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug sasl tcpd"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib
+ sasl? ( dev-libs/cyrus-sasl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch \
+ "${FILESDIR}"/${PN}-3.0.7.3-DLT_IPNET.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers) $(use_with sasl)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/*.5 man/man8/*.8
+
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ keepdir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that the init script will fail to work."
+}
diff --git a/net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch b/net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch
new file mode 100644
index 000000000000..77bde434282c
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -270,6 +270,11 @@
+ LIBS="$LIBS $V_PCAPDEP"
+ fi
+
++AC_ARG_WITH(wrappers,
++ [ --with-wrappers build with libwrappers suuport],
++ with_wrappers="$withval",
++ with_wrappers="yes")
++if test "x$with_wrappers" != "xno"; then
+ AC_QOSIENT_TCPWRAP(V_WRAPDEP, V_INCLS)
+ if test ! -z "$V_WRAPDEP"; then
+ if test -f $V_WRAPDEP; then
+@@ -293,6 +298,7 @@
+ AC_DEFINE([HAVE_TCP_WRAPPER], [], [Using Tcp wrappers])
+ WRAPLIBS="$V_WRAPDEP"
+ fi
++fi
+
+ AC_CHECK_FUNCS(xdrmem_create)
+ if test "$ac_cv_func_xdrmem_create" = yes; then
diff --git a/net-analyzer/argus/files/argus-3.0.5-Makefile.patch b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
new file mode 100644
index 000000000000..87b1c155caf8
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
@@ -0,0 +1,20 @@
+Do not continue when a sub-make errors (bug #380953).
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -55,11 +55,11 @@
+ .PHONY: install installdirs all
+
+ all: force
+- @-for d in $(DIRS);\
++ @for d in $(DIRS);\
+ do \
+- (cd $$d; echo "### Making in" `pwd`;\
+- $(MAKE) $(MFLAGS) ;\
+- echo "### Done with" `pwd`);\
++ echo "### Making in" $$d;\
++ $(MAKE) -C $$d $(MFLAGS) || exit 1;\
++ echo "### Done with" $$d;\
+ done
+
+ install: force
diff --git a/net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch b/net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch
new file mode 100644
index 000000000000..f7b4bfa4cc6c
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch
@@ -0,0 +1,17 @@
+In file included from ./ArgusModeler.h:330:0,
+ from ./argus.h:40,
+ from ArgusSource.c:67:
+./ArgusSource.h:893:6: error: ‘ArgusIpNetPacket’ undeclared here (not in a function)
+
+--- a/argus/ArgusSource.h
++++ b/argus/ArgusSource.h
+@@ -889,9 +889,6 @@
+ #ifdef DLT_JUNIPER_ETHER
+ { ArgusJuniperPacket, DLT_JUNIPER_ETHER, "ArgusJuniperPacket()" },
+ #endif
+-#ifdef DLT_IPNET
+- { ArgusIpNetPacket, DLT_IPNET, "ArgusIpNetPacket()" },
+-#endif
+ { NULL, DLT_NULL, "" },
+ #endif
+ { NULL, 0, NULL},
diff --git a/net-analyzer/argus/files/argus-3.0.8.1-disable-tcp-wrappers-automagic.patch b/net-analyzer/argus/files/argus-3.0.8.1-disable-tcp-wrappers-automagic.patch
new file mode 100644
index 000000000000..917f864cf065
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.8.1-disable-tcp-wrappers-automagic.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -251,6 +251,11 @@
+ AC_QOSIENT_MEMORY
+
+ AC_QOSIENT_THREADS(V_THREADS)
++AC_ARG_WITH(wrappers,
++ [ --with-wrappers build with libwrappers support],
++ with_wrappers="$withval",
++ with_wrappers="yes")
++if test "x$with_wrappers" != "xno"; then
+ AC_QOSIENT_TCPWRAP(V_WRAPDEP, V_INCLS)
+ if test ! -z "$V_WRAPDEP"; then
+ if test -f "$V_WRAPDEP"; then
+@@ -274,6 +279,7 @@
+ AC_DEFINE([HAVE_TCP_WRAPPER], [], [Using Tcp wrappers])
+ WRAPLIBS="$V_WRAPDEP"
+ fi
++fi
+
+ AC_QOSIENT_LIBPCAP(V_PCAPDEP, V_INCLS)
+ if test ! -z "$V_PCAPDEP"; then
diff --git a/net-analyzer/argus/files/argus.initd b/net-analyzer/argus/files/argus.initd
new file mode 100644
index 000000000000..cbc8cfdd112c
--- /dev/null
+++ b/net-analyzer/argus/files/argus.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting argus"
+ start-stop-daemon --start --quiet --exec /usr/sbin/argus -- -d
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping argus"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/argus
+ eend $?
+}
diff --git a/net-analyzer/argus/metadata.xml b/net-analyzer/argus/metadata.xml
new file mode 100644
index 000000000000..a688da311250
--- /dev/null
+++ b/net-analyzer/argus/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>network Audit Record Generation and Utilization System</longdescription>
+</pkgmetadata>