summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 12:43:34 +0000
committerSam James <sam@gentoo.org>2021-03-16 13:09:28 +0000
commitba005557677479277cb36d580ccca5872123992a (patch)
tree81f0e9ffbc7bad92075a8b5775974d320791ed27 /net-analyzer/alive/alive-2.0.3.ebuild
parentdev-scheme/xdgdirs: initial import (diff)
downloadgentoo-ba005557677479277cb36d580ccca5872123992a.tar.gz
gentoo-ba005557677479277cb36d580ccca5872123992a.tar.bz2
gentoo-ba005557677479277cb36d580ccca5872123992a.zip
net-analyzer/alive: add 2.0.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/alive/alive-2.0.3.ebuild')
-rw-r--r--net-analyzer/alive/alive-2.0.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/alive/alive-2.0.3.ebuild b/net-analyzer/alive/alive-2.0.3.ebuild
new file mode 100644
index 000000000000..89a15d6ada23
--- /dev/null
+++ b/net-analyzer/alive/alive-2.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-arch/xz-utils"
+DEPEND="
+ dev-scheme/guile
+"
+RDEPEND="
+ ${DEPEND}
+ dev-scheme/xdgdirs
+ net-misc/iputils
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-ping-test.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}