summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-01-14 14:04:13 +0100
committerLouis Sautier <sautier.louis@gmail.com>2016-01-15 15:19:28 +0100
commitafc11d55b4dadd42257f9629aefd5d26e9b25b12 (patch)
tree204e8da6a6cfe2e7712b1af372bc0adf452816ba /media-video/tsmuxer/tsmuxer-2.6.11.ebuild
parentapp-admin/ansible: do not install obsolete env file (diff)
downloadgentoo-afc11d55b4dadd42257f9629aefd5d26e9b25b12.tar.gz
gentoo-afc11d55b4dadd42257f9629aefd5d26e9b25b12.tar.bz2
gentoo-afc11d55b4dadd42257f9629aefd5d26e9b25b12.zip
media-video/tsmuxer: bump to vn. 2.6.11, update homepage #536808
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-video/tsmuxer/tsmuxer-2.6.11.ebuild')
-rw-r--r--media-video/tsmuxer/tsmuxer-2.6.11.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-video/tsmuxer/tsmuxer-2.6.11.ebuild b/media-video/tsmuxer/tsmuxer-2.6.11.ebuild
new file mode 100644
index 000000000000..0d27b71fb8cc
--- /dev/null
+++ b/media-video/tsmuxer/tsmuxer-2.6.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Utility to create and demux TS and M2TS files"
+HOMEPAGE="http://forum.doom9.org/showthread.php?t=168539"
+SRC_URI="https://drive.google.com/uc?export=download&id=0B0VmPcEZTp8NekJxLUVJRWMwejQ -> ${P}.tar.gz
+ http://gentoo.sbriesen.de/distfiles/tsmuxer-icon.png"
+LICENSE="SmartLabs"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+QA_FLAGS_IGNORED="opt/${PN}/bin/tsMuxeR opt/${PN}/bin/tsMuxerGUI"
+
+DEPEND="|| (
+ >=app-arch/upx-ucl-3.01[lzma]
+ >=app-arch/upx-bin-3.01
+)"
+RDEPEND="
+ >=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)]
+ qt4? (
+ >=dev-libs/glib-2.34.3:2[abi_x86_32(-)]
+ >=dev-qt/qtcore-4.8.5-r1:4[abi_x86_32(-)]
+ >=dev-qt/qtgui-4.8.5-r2:4[abi_x86_32(-)]
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ >=media-libs/libpng-1.2.51:1.2[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ )
+"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ upx -d tsMuxeR tsMuxerGUI || die
+}
+
+src_install() {
+ dodir /opt/bin
+ exeinto /opt/${PN}/bin
+
+ doexe tsMuxeR
+ dosym ../${PN}/bin/tsMuxeR /opt/bin/tsMuxeR
+
+ if use qt4; then
+ doexe tsMuxerGUI
+ dosym ../${PN}/bin/tsMuxerGUI /opt/bin/tsMuxerGUI
+ newicon "${DISTDIR}/${PN}-icon.png" "${PN}.png"
+ make_desktop_entry tsMuxerGUI "tsMuxeR GUI" "${PN}" "Qt;AudioVideo;Video"
+ fi
+}