summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/subtitleeditor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/Manifest1
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch30
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.41.0-subtitle-edition.patch27
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch16
-rw-r--r--media-video/subtitleeditor/metadata.xml13
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild72
6 files changed, 159 insertions, 0 deletions
diff --git a/media-video/subtitleeditor/Manifest b/media-video/subtitleeditor/Manifest
new file mode 100644
index 000000000000..75a4bb2b8e58
--- /dev/null
+++ b/media-video/subtitleeditor/Manifest
@@ -0,0 +1 @@
+DIST subtitleeditor-0.41.1.tar.gz 1637940 SHA256 3183f2f9831359f2200194fcc2d360198094c494892ccacd08a28717bffac0d0 SHA512 6e87df6bf1b97fc085387f331fa415be48086b9dabf445e6050ff3ab3c812c8fff72e613959308f07c2e849bf95064c5d288f44dbc266997e7143bbb46615c9d WHIRLPOOL 111163dde1cf17df34e0dfb0aeeb874a98095d6d338ca22138ff13747697d78a2d1be127f344c36286b79f828918ab1c615bccc7e04cc8586b12efe407c76f52
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch
new file mode 100644
index 000000000000..b347d4ce4261
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch
@@ -0,0 +1,30 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Prevent crash when generating keyframes with gstreamermm 0.10.11
+--- a/plugins/actions/keyframesmanagement/keyframesgenerator.cc
++++ b/plugins/actions/keyframesmanagement/keyframesgenerator.cc
+@@ -87,12 +87,20 @@
+ if(structure_name.find("video") == Glib::ustring::npos)
+ return Glib::RefPtr<Gst::Element>(NULL);
+
+- Glib::RefPtr<Gst::Bin> videobin = Glib::RefPtr<Gst::Bin>::cast_dynamic(
+- Gst::Parse::create_bin(
+- "ffmpegcolorspace ! fakesink name=vsink", true));
++ // ffmpegcolorspace
++ Glib::RefPtr<Gst::Element> conv = Gst::ElementFactory::create_element("ffmpegcolorspace", "conv");
++ // fakesink
++ Glib::RefPtr<Gst::FakeSink> vsink = Gst::FakeSink::create("vsink");
++ // videobin
++ Glib::RefPtr<Gst::Bin> videobin = Gst::Bin::create("videobin");
+
+- Glib::RefPtr<Gst::FakeSink> vsink = Glib::RefPtr<Gst::FakeSink>::cast_dynamic(
+- videobin->get_element("vsink"));
++ // Add and link
++ videobin->add(conv)->add(vsink);
++ conv->link_pads("src", vsink, "sink");
++
++ // Add sink pad to bin element
++ Glib::RefPtr<Gst::Pad> pad = conv->get_static_pad("sink");
++ videobin->add_pad(Gst::GhostPad::create(pad, "sink"));
+
+ vsink->set_sync(false);
+ vsink->property_silent() = true;
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.41.0-subtitle-edition.patch b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-subtitle-edition.patch
new file mode 100644
index 000000000000..eff958fd66cc
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-subtitle-edition.patch
@@ -0,0 +1,27 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: With glib >= 2.42.0 you need to add interfaces before class_init
+--- a/src/gui/textviewcell.cc
++++ b/src/gui/textviewcell.cc
+@@ -30,8 +30,8 @@
+ * Initialize the widget with the AutomaticSpellChecker.
+ */
+ TextViewCell::TextViewCell()
++: Gtk::CellEditable(),
++ Glib::ObjectBase(typeid(TextViewCell)),
+-: Glib::ObjectBase(typeid(TextViewCell)),
+- Gtk::CellEditable(),
+ m_editing_canceled(false),
+ m_used_ctrl_enter_to_confirm_change(false)
+ {
+
+--- a/src/gui/textviewcell.h
++++ b/src/gui/textviewcell.h
+@@ -29,7 +29,7 @@
+ /*
+ * Cell text editable with multiline support.
+ */
+-class TextViewCell : public Gtk::TextView, public Gtk::CellEditable
++class TextViewCell : public Gtk::CellEditable, public Gtk::TextView
+ {
+ public:
+
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch
new file mode 100644
index 000000000000..7a8552c7a71f
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch
@@ -0,0 +1,16 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Get textoverlay working with gstreamermm 0.10.11
+--- a/src/vp/gstplayer.cc
++++ b/src/vp/gstplayer.cc
+@@ -656,7 +656,10 @@
+ "Please check your GStreamer installation."), "ffmpegcolorspace"));
+ }
+ // textoverlay
+- textoverlay = Gst::ElementFactory::create_element("textoverlay", "overlay");
++ // Workaround to prevent getting a NULL pointer from the
++ // cast_dynamic(textoverlay) call under gstreamermm 0.10.11
++ textoverlay = Gst::TextOverlay::create("overlay");
++
+ if(!textoverlay)
+ {
+ throw std::runtime_error(
diff --git a/media-video/subtitleeditor/metadata.xml b/media-video/subtitleeditor/metadata.xml
new file mode 100644
index 000000000000..58bbb44bf7bc
--- /dev/null
+++ b/media-video/subtitleeditor/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+<longdescription lang="en">
+Subtitle Editor is a GTK+2 tool to edit subtitles for GNU/Linux/*BSD. It can be used for new subtitles or as a tool to transform, edit, correct and refine existing subtitle. This program also shows sound waves, which makes it easier to synchronise subtitles to voices.
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild b/media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild
new file mode 100644
index 000000000000..7b161619fbde
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator flag-o-matic
+
+DESCRIPTION="GTK+2 subtitle editing tool"
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug nls opengl"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-cpp/cairomm
+ >=dev-cpp/gtkmm-2.14:2.4
+ >=dev-cpp/glibmm-2.16.3:2
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ >=dev-cpp/libxmlpp-2.20:2.6
+ >=app-text/enchant-1.4
+ >=dev-cpp/gstreamermm-0.10.6:0.10
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ >=media-libs/gst-plugins-good-0.10:0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-pango-0.10:0.10
+ >=media-plugins/gst-plugins-xvideo-0.10:0.10
+ x11-libs/gtk+:2
+ virtual/libintl
+ opengl? (
+ >=dev-cpp/gtkglextmm-1.2:1.0
+ virtual/opengl )
+"
+# gst-plugins-pango needed for text overlay
+# gst-plugins-xvideo needed for video output
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Get textoverlay working with gstreamermm 0.10.11
+ epatch "${FILESDIR}"/${PN}-0.41.0-textoverlay.patch
+
+ # Prevent crash when generating keyframes with gstreamermm 0.10.11
+ epatch "${FILESDIR}"/${PN}-0.41.0-keyframe-generation.patch
+
+ # Fix typing/editing subtitle, bug #536246
+ epatch "${FILESDIR}"/${PN}-0.41.0-subtitle-edition.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
+ use debug && append-flags -DDEBUG
+
+ gnome2_src_configure \
+ --disable-debug \
+ $(use_enable nls) \
+ $(use_enable opengl gl)
+}