summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-14 11:36:04 +0000
committerSam James <sam@gentoo.org>2023-11-14 11:41:27 +0000
commita072bf78d8bcfa90a5e6d69e9ca88fc013c1b5a3 (patch)
treef09508709ec7e556f97f9f2add74eb73aa7f1f73 /media-video/ffmpeg/ffmpeg-9999.ebuild
parentdev-libs/libgcrypt: don't try to use mlock in tests (diff)
downloadgentoo-a072bf78d8bcfa90a5e6d69e9ca88fc013c1b5a3.tar.gz
gentoo-a072bf78d8bcfa90a5e6d69e9ca88fc013c1b5a3.tar.bz2
gentoo-a072bf78d8bcfa90a5e6d69e9ca88fc013c1b5a3.zip
media-video/ffmpeg: add -k for tests to get full results
We want full results even if one test fails - this is the general principle we follow in other tests, and feels in the spirit of the verbose logs policy too. We really don't want to play whack-a-mole if a user reports an issue, better to see the full thing. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index b3a18c95e2fd..9d0e86211982 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -565,7 +565,7 @@ multilib_src_compile() {
multilib_src_test() {
LD_LIBRARY_PATH="${BUILD_DIR}/libpostproc:${BUILD_DIR}/libswscale:${BUILD_DIR}/libswresample:${BUILD_DIR}/libavcodec:${BUILD_DIR}/libavdevice:${BUILD_DIR}/libavfilter:${BUILD_DIR}/libavformat:${BUILD_DIR}/libavutil" \
- emake V=1 fate
+ emake V=1 fate -k
}
multilib_src_install() {