summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/alevt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/alevt')
-rw-r--r--media-video/alevt/Manifest1
-rw-r--r--media-video/alevt/alevt-1.6.2.ebuild48
-rw-r--r--media-video/alevt/files/alevt-1.6.2-libpng15.patch11
-rw-r--r--media-video/alevt/files/alevt-1.6.2-respectflags.patch34
-rw-r--r--media-video/alevt/metadata.xml5
5 files changed, 99 insertions, 0 deletions
diff --git a/media-video/alevt/Manifest b/media-video/alevt/Manifest
new file mode 100644
index 000000000000..617e56349151
--- /dev/null
+++ b/media-video/alevt/Manifest
@@ -0,0 +1 @@
+DIST alevt-1.6.2.tar.gz 133234 RMD160 19bab54e5d5c22cd18d73229524ddc87636850ab SHA1 17f661a22f11f648215efd8d73e1b4dc4a06c5e2 SHA256 9347c2af4b528edec87df8a424ddccebcc252ca7a06f6b18310733cfa547e5f5
diff --git a/media-video/alevt/alevt-1.6.2.ebuild b/media-video/alevt/alevt-1.6.2.ebuild
new file mode 100644
index 000000000000..a2b3f485e6bd
--- /dev/null
+++ b/media-video/alevt/alevt-1.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Teletext viewer for X11"
+HOMEPAGE="http://www.goron.de/~froese/"
+SRC_URI="http://www.goron.de/~froese/alevt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=media-libs/libpng-1.4"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+RESTRICT="strip"
+
+src_prepare() {
+ cp -va Makefile{,.orig}
+
+ epatch \
+ "${FILESDIR}"/${P}-respectflags.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin alevt alevt-cap alevt-date
+ doman alevt.1x alevt-date.1 alevt-cap.1
+ dodoc CHANGELOG README
+
+ insinto /usr/share/icons/hicolor/16x16/apps
+ newins contrib/mini-alevt.xpm alevt.xpm
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins contrib/icon48x48.xpm alevt.xpm
+
+ make_desktop_entry alevt "AleVT" alevt
+}
diff --git a/media-video/alevt/files/alevt-1.6.2-libpng15.patch b/media-video/alevt/files/alevt-1.6.2-libpng15.patch
new file mode 100644
index 000000000000..337a6f7c709f
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.2-libpng15.patch
@@ -0,0 +1,11 @@
+--- exp-gfx.c
++++ exp-gfx.c
+@@ -4,6 +4,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#include <zlib.h> /* Z_DEFAULT_COMPRESSION */
++
+ #include "lang.h"
+ #include "export.h"
+
diff --git a/media-video/alevt/files/alevt-1.6.2-respectflags.patch b/media-video/alevt/files/alevt-1.6.2-respectflags.patch
new file mode 100644
index 000000000000..368b0ff614cd
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.2-respectflags.patch
@@ -0,0 +1,34 @@
+--- alevt-1.6.2/Makefile.orig 2007-12-03 06:19:54.000000000 +0100
++++ alevt-1.6.2/Makefile 2009-05-14 10:17:39.000000000 +0200
+@@ -1,5 +1,4 @@
+ VER=1.6.2
+-OPT=-O2 -s -w
+ #OPT=-O -g
+ DEFS=-DWITH_PNG
+ FONT=vtxt
+@@ -11,7 +10,7 @@
+ # a smaller and thinner font
+ #FONT=neep9
+
+-CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
++CFLAGS += -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
+
+ EXPOBJS=export.o exp-txt.o exp-html.o exp-gfx.o font.o
+ OBJS=main.o ui.o xio.o fdset.o vbi.o cache.o help.o edline.o search.o edit.o misc.o hamm.o lang.o $(EXPOBJS)
+@@ -25,13 +24,13 @@
+ all: alevt alevt-date alevt-cap alevt.1x alevt-date.1 alevt-cap.1
+
+ alevt: $(OBJS)
+- $(CC) $(OPT) $(OBJS) -o alevt -L$(USR_X11R6)/lib -L$(USR_X11R6)/lib64 -lX11 $(EXPLIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o alevt -L$(USR_X11R6)/lib -L$(USR_X11R6)/lib64 -lX11 $(EXPLIBS)
+
+ alevt-date: $(TOBJS)
+- $(CC) $(OPT) $(TOBJS) -o alevt-date
++ $(CC) $(CFLAGS) $(LDFLAGS) $(TOBJS) -o alevt-date
+
+ alevt-cap: $(COBJS)
+- $(CC) $(OPT) $(COBJS) -o alevt-cap $(EXPLIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(COBJS) -o alevt-cap $(EXPLIBS)
+
+ font.o: font1.xbm font2.xbm
+ fontsize.h: font1.xbm font2.xbm
diff --git a/media-video/alevt/metadata.xml b/media-video/alevt/metadata.xml
new file mode 100644
index 000000000000..a6b9e38a1b93
--- /dev/null
+++ b/media-video/alevt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+</pkgmetadata>