summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/shoutcast-trans-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/shoutcast-trans-bin')
-rw-r--r--media-sound/shoutcast-trans-bin/Manifest1
-rw-r--r--media-sound/shoutcast-trans-bin/files/shoutcast_trans32
-rw-r--r--media-sound/shoutcast-trans-bin/metadata.xml5
-rw-r--r--media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0-r1.ebuild67
4 files changed, 105 insertions, 0 deletions
diff --git a/media-sound/shoutcast-trans-bin/Manifest b/media-sound/shoutcast-trans-bin/Manifest
new file mode 100644
index 000000000000..071e4afa1776
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/Manifest
@@ -0,0 +1 @@
+DIST sc_trans_posix_040.tgz 351390 SHA256 b2aea79b034f227fcadc10c1c45bab769fa00b9a4990d849e73028872c95e232
diff --git a/media-sound/shoutcast-trans-bin/files/shoutcast_trans b/media-sound/shoutcast-trans-bin/files/shoutcast_trans
new file mode 100644
index 000000000000..4d4a779db3e4
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/files/shoutcast_trans
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+ need shoutcast
+}
+
+checkconfig() {
+ if ! [ -f /etc/shoutcast/sc_trans.conf ] ; then
+ eerror "Configuration file /etc/shoutcast/sc_trans.conf does not exist!"
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Shoutcast Trans"
+ start-stop-daemon --start --quiet -m --pidfile /var/run/shoutcast_trans.pid --exec /opt/shoutcast/sc_trans_linux /etc/shoutcast/sc_trans.conf > /dev/null &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Shoutcast Trans"
+ start-stop-daemon --stop --quiet --pidfile /var/run/shoutcast_trans.pid
+ eend $?
+}
diff --git a/media-sound/shoutcast-trans-bin/metadata.xml b/media-sound/shoutcast-trans-bin/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0-r1.ebuild b/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..910ebae7510c
--- /dev/null
+++ b/media-sound/shoutcast-trans-bin/shoutcast-trans-bin-0.4.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+SVER=${PV//./}
+
+DESCRIPTION="A transcoder that provides a source for shoutcast-server-bin to stream from"
+HOMEPAGE="http://www.shoutcast.com/"
+SRC_URI="http://yp.shoutcast.com/downloads/sc_trans_posix_${SVER}.tgz"
+
+LICENSE="shoutcast"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+RDEPEND="media-sound/shoutcast-server-bin"
+
+S=${WORKDIR}/sc_trans_${SVER}
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Download sc_trans_posix_${SVER}.tgz from ${HOMEPAGE}."
+ einfo "Last known working location is ${SRC_URI}."
+}
+
+src_install() {
+ # install executable
+ exeinto /opt/shoutcast
+ doexe sc_trans_linux
+
+ # install the init.d file
+ doinitd "${FILESDIR}"/shoutcast_trans
+
+ # install sample configuration file
+ dodoc example.lst
+ cp sc_trans.conf sc_trans.conf.example
+ dodoc sc_trans.conf.example
+
+ # install configuration file
+ sed -e "s/LogFile=sc_trans\.log/LogFile=\/dev\/null/" -i sc_trans.conf
+ # filter out some midly offensive stuff in the config file
+ sed -e "s|^StreamTitle=.*|StreamTitle=Example Stream|" -i sc_trans.conf
+ sed -e "s|^StreamURL=.*|StreamURL=http://examplestream.com/|" -i sc_trans.conf
+ sed -e "s|^PlaylistFile=.*|PlaylistFile=/opt/shoutcast/playlists/example.lst|" -i sc_trans.conf
+ insinto /etc/shoutcast
+ doins sc_trans.conf
+
+ # create a directory for playlists to be put
+ keepdir /opt/shoutcast/playlists
+
+ # Fix permissions - security bug #63551
+ fperms 600 /etc/shoutcast/sc_trans.conf
+}
+
+pkg_postinst() {
+ elog "Shoutcast-trans can be started via the init.d script provided."
+ elog "start it with /etc/init.d/shoutcast_trans"
+ elog
+ elog "The configuration file is /etc/shoutcast/sc_trans.conf."
+ elog "Please have a look at the playlist file setting."
+ elog "A sample playlist file can be found under /usr/share/doc/$P."
+ elog "It also contains instructions how to build a playlist."
+ elog "A directory /opt/shoutcast/playlists has been created for storing playlists."
+}