summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2021-07-04 22:31:58 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-04 22:31:58 +0200
commit3e2b16e0ca6ad0a80f2e971d6aa11a9eae281124 (patch)
treea7079996570675003ed9c4b89bdfc780a9e31797 /media-sound/scream
parentprofiles/arch/x86: re-enable stellarium[nls] (diff)
downloadgentoo-3e2b16e0ca6ad0a80f2e971d6aa11a9eae281124.tar.gz
gentoo-3e2b16e0ca6ad0a80f2e971d6aa11a9eae281124.tar.bz2
gentoo-3e2b16e0ca6ad0a80f2e971d6aa11a9eae281124.zip
media-sound/scream: add 3.7
Closes: https://github.com/gentoo/gentoo/pull/21308 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/scream')
-rw-r--r--media-sound/scream/Manifest1
-rw-r--r--media-sound/scream/scream-3.7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/scream/Manifest b/media-sound/scream/Manifest
index d7e02efe74da..56f199b270f0 100644
--- a/media-sound/scream/Manifest
+++ b/media-sound/scream/Manifest
@@ -1 +1,2 @@
DIST scream-3.6.tar.gz 999237 BLAKE2B d199d9658958ac53d973c25421ee3a7f2c1ec9666c34596639942bcbfa5efb60e4aad033adc2fdbd810f676f412357283dc5fda6224752587498f7636ade1662 SHA512 4fd07a808d8f0ead3551061e96fe2f9b54ef6f34d1d615fb6454185fc6ffc67f71afb08a876550363cb3f8c15bbff461936808031e5aba5885626c92880e92ec
+DIST scream-3.7.tar.gz 1021097 BLAKE2B b7918359d71852cc923bcfebd7f01b7ecec12146199b99d50840d02748410cbead6b385ebcbbced20d9d75771a4331220547276a65e86281bbe5072b8af9bbf7 SHA512 5801bed5fff40d17548edb689f37b277bdba7520ab1c0daa4fad79429ade6ad806f90e4197c753f2257bac84ff4f7cc1e2c1209102b60a5bc001b92d42b4ceda
diff --git a/media-sound/scream/scream-3.7.ebuild b/media-sound/scream/scream-3.7.ebuild
new file mode 100644
index 000000000000..019926a23b77
--- /dev/null
+++ b/media-sound/scream/scream-3.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
+HOMEPAGE="https://github.com/duncanthrax/scream"
+S="${WORKDIR}/${P}/Receivers/unix"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
+else
+ SRC_URI="https://github.com/duncanthrax/scream/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Ms-PL"
+SLOT="0"
+IUSE="alsa jack pulseaudio"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ jack? (
+ media-libs/soxr
+ virtual/jack
+ )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DALSA_ENABLE=$(usex alsa)
+ -DJACK_ENABLE=$(usex jack)
+ -DPULSEAUDIO_ENABLE=$(usex pulseaudio)
+ )
+ cmake_src_configure
+}