summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-11 21:45:11 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-11 21:47:14 +0100
commit6a898fff45993a04ecd991c29c15c92b86400c4e (patch)
tree3650c0e83a54e9c03202f1f9dbd32bbd554ee8ee /media-sound/rexima
parentmedia-sound/takcd: Modernise to EAPI 6 (diff)
downloadgentoo-6a898fff45993a04ecd991c29c15c92b86400c4e.tar.gz
gentoo-6a898fff45993a04ecd991c29c15c92b86400c4e.tar.bz2
gentoo-6a898fff45993a04ecd991c29c15c92b86400c4e.zip
media-sound/rexima: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/rexima')
-rw-r--r--media-sound/rexima/rexima-1.4-r1.ebuild (renamed from media-sound/rexima/rexima-1.4.ebuild)26
1 files changed, 16 insertions, 10 deletions
diff --git a/media-sound/rexima/rexima-1.4.ebuild b/media-sound/rexima/rexima-1.4-r1.ebuild
index cdfc20bdfade..cd78692ee670 100644
--- a/media-sound/rexima/rexima-1.4.ebuild
+++ b/media-sound/rexima/rexima-1.4-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="A curses-based interactive mixer which can also be used from the command-line"
@@ -12,18 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}"
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
-src_compile() {
+src_configure() {
tc-export CC
- echo "LDLIBS=-lncurses" > Makefile
- echo "all: rexima" >> Makefile
- emake || die "emake failed"
+
+ cat > Makefile <<- _EOF_ || die
+ LDLIBS=$($(tc-getPKG_CONFIG) --libs ncurses)
+ all: rexima
+ _EOF_
}
src_install () {
- dobin rexima || die
- doman rexima.1 || die
- dodoc NEWS README ChangeLog
+ dobin rexima
+
+ einstalldocs
+ doman rexima.1
}