summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mp3check
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mp3check')
-rw-r--r--media-sound/mp3check/Manifest2
-rw-r--r--media-sound/mp3check/metadata.xml5
-rw-r--r--media-sound/mp3check/mp3check-0.8.4.ebuild27
-rw-r--r--media-sound/mp3check/mp3check-0.8.7.ebuild34
4 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/mp3check/Manifest b/media-sound/mp3check/Manifest
new file mode 100644
index 000000000000..2ed203613346
--- /dev/null
+++ b/media-sound/mp3check/Manifest
@@ -0,0 +1,2 @@
+DIST mp3check-0.8.4.tgz 71396 SHA256 952f271aab86adf89e2391503bf46a6ddbd838b7bd1ea19756d004f143dbfaa9
+DIST mp3check-0.8.7.tgz 71629 SHA256 27d976ad8495671e9b9ce3c02e70cb834d962b6fdf1a7d437bb0e85454acdd0e SHA512 5b5c9bde0cc7fd9dc02de53e4ccc3e403001547c06121be57f8f693b9224302d24f0c84f928b329b0f69c67dd4fb51fa3b60368f57a9446476d8344417bd09fd WHIRLPOOL f3d12ed391fb3a520899f228363b418ceb8e36f7bd9b3609f672baecd174ad04500af788e6c25e31aa7a6c14adcfd5ffcb8662e33cca06c6a5e13801f5d7c08f
diff --git a/media-sound/mp3check/metadata.xml b/media-sound/mp3check/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/mp3check/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/mp3check/mp3check-0.8.4.ebuild b/media-sound/mp3check/mp3check-0.8.4.ebuild
new file mode 100644
index 000000000000..516f31e1fbc2
--- /dev/null
+++ b/media-sound/mp3check/mp3check-0.8.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
+HOMEPAGE="http://jo.ath.cx/soft/mp3check/index.html"
+SRC_URI="http://jo.ath.cx/soft/mp3check/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "/^WARN/s/-g//" Makefile || die
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" OPT="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin mp3check
+}
diff --git a/media-sound/mp3check/mp3check-0.8.7.ebuild b/media-sound/mp3check/mp3check-0.8.7.ebuild
new file mode 100644
index 000000000000..506d7f12cf94
--- /dev/null
+++ b/media-sound/mp3check/mp3check-0.8.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
+HOMEPAGE="http://code.google.com/p/mp3check/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e '/^WARN/s:-g::' Makefile || die
+}
+
+src_configure() {
+ # tfiletools.h:59:50: warning: dereferencing type-punned pointer will break
+ # strict-aliasing rules [-Wstrict-aliasing]
+ append-cxxflags -fno-strict-aliasing
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" OPT="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman *.1
+}