summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mp3cat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mp3cat')
-rw-r--r--media-sound/mp3cat/Manifest1
-rw-r--r--media-sound/mp3cat/metadata.xml5
-rw-r--r--media-sound/mp3cat/mp3cat-0.4.ebuild29
3 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/mp3cat/Manifest b/media-sound/mp3cat/Manifest
new file mode 100644
index 000000000000..9b0610f51be4
--- /dev/null
+++ b/media-sound/mp3cat/Manifest
@@ -0,0 +1 @@
+DIST mp3cat-0.4.tar.gz 14956 SHA256 fd2b0d58018f5117bd1e22298c899bef5e6af61a0c540186d16d2bf516d6849a SHA512 a72bbbd296bb07a7e7fc084a494b2676c012cf3a4c71ace7eea52892f6f478769c5b6140fcd8dbfa245d537335a484fd8c5db15edd83a0146821d48e24862492 WHIRLPOOL 578b34557b11eabc94e42f8a78c03ad99866354b1ec2c63bfe635b0475f402a7ea23956e433d911a94dbb0f419e14cb959b6263e74da5396b5fe58fcad51c3fa
diff --git a/media-sound/mp3cat/metadata.xml b/media-sound/mp3cat/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/mp3cat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/mp3cat/mp3cat-0.4.ebuild b/media-sound/mp3cat/mp3cat-0.4.ebuild
new file mode 100644
index 000000000000..ad038f56976a
--- /dev/null
+++ b/media-sound/mp3cat/mp3cat-0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="mp3cat reads and writes MP3 files"
+HOMEPAGE="http://tomclegg.net/mp3cat"
+SRC_URI="http://tomclegg.net/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i -e 's:cc -o:${CC} ${CFLAGS} ${LDFLAGS} -o:' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin mp3cat mp3log mp3log-conf mp3dirclean mp3http mp3stream-conf
+}