summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/listen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/listen')
-rw-r--r--media-sound/listen/Manifest1
-rw-r--r--media-sound/listen/files/listen-0.6.5-Makefile.patch32
-rw-r--r--media-sound/listen/listen-0.6.5-r1.ebuild59
-rw-r--r--media-sound/listen/metadata.xml34
4 files changed, 126 insertions, 0 deletions
diff --git a/media-sound/listen/Manifest b/media-sound/listen/Manifest
new file mode 100644
index 000000000000..8ab63aea145c
--- /dev/null
+++ b/media-sound/listen/Manifest
@@ -0,0 +1 @@
+DIST listen-0.6.5.tar.gz 984613 SHA256 23a4d33ef3251c529ac9a78d992557a2498fa05b825e76c9ab4bad431ed6c61a SHA512 aa772077603f0796f4ec5376c2ec3d1d67ca6a85a489ab6589258c75aafb58a525e2c803663ecfc31de789348e5b9cc7e380fc439dd1bd76292f1e798b305cce WHIRLPOOL a84964ad172a66c5f432cdd7f3f8a6b4ac3d8fbe7d9c92b77bbef5ffe30e97ddd8c2670b8b8e7b0ecc81ce1109e2668553d67f8e990dd19398e60d06dbb39409
diff --git a/media-sound/listen/files/listen-0.6.5-Makefile.patch b/media-sound/listen/files/listen-0.6.5-Makefile.patch
new file mode 100644
index 000000000000..5d13bbc30237
--- /dev/null
+++ b/media-sound/listen/files/listen-0.6.5-Makefile.patch
@@ -0,0 +1,32 @@
+--- Makefile
++++ Makefile
+@@ -50,10 +50,8 @@
+ echo 'Name=org.gnome.Listen' >> org.gnome.Listen.service
+ echo 'Exec=$(BINDIR)/listen' >> org.gnome.Listen.service
+
+- docbook2x-man misc/listen.1.docbook --to-stdout | gzip > listen.1.gz
++ docbook2man.pl misc/listen.1.docbook
+
+- python -m compileall src
+- python -O -m compileall src
+ @echo "Done"
+ @echo "Type: make install now"
+
+@@ -104,8 +102,6 @@
+
+ install: make-install-dirs
+ install -m 644 src/*.py $(DESTDIR)$(LIBDIR)/listen
+- install -m 644 src/*.pyc $(DESTDIR)$(LIBDIR)/listen
+- install -m 644 src/*.pyo $(DESTDIR)$(LIBDIR)/listen
+ for dir in $(PYSRC_DIR); do \
+ for file in src/$${dir}/*.py; do \
+ grep '^#@nodistribution' $$file >/dev/null && echo "$$file not distribued" && continue ; \
+@@ -122,7 +118,7 @@
+ install -m 644 data/img/listen.png $(DESTDIR)$(DATADIR)/pixmaps/
+
+ install -m 644 listen.desktop $(DESTDIR)$(DATADIR)/applications/
+- install -m 644 listen.1.gz $(DESTDIR)$(MANDIR)/man1/
++ install -m 644 listen.1 $(DESTDIR)$(MANDIR)/man1/
+ install -m 644 org.gnome.Listen.service $(DESTDIR)$(DBUSDIR)/services
+
+ for lang in $(PO); do install -m 644 po/$$lang.mo $(DESTDIR)$(LOCALEDIR)/$$lang/LC_MESSAGES/listen.mo; done
diff --git a/media-sound/listen/listen-0.6.5-r1.ebuild b/media-sound/listen/listen-0.6.5-r1.ebuild
new file mode 100644
index 000000000000..61fcfa7733ec
--- /dev/null
+++ b/media-sound/listen/listen-0.6.5-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils multilib python-single-r1
+
+DESCRIPTION="A music management and playback for GTK+ based desktops"
+HOMEPAGE="http://www.listen-project.org/"
+SRC_URI="http://download.listen-project.org/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdda"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.8:2[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ || ( dev-python/python-xlib[${PYTHON_USEDEP}] dev-python/egg-python[${PYTHON_USEDEP}] )
+ dev-python/pywebkitgtk
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ media-libs/libgpod[python]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ media-plugins/gst-plugins-meta:0.10
+ x11-libs/libnotify
+ cdda? ( dev-python/python-musicbrainz[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-text/docbook2X
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ !media-radio/ax25-apps"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ sed -i -e 's:audip/mp3:audio/mp3:' misc/listen.desktop.in || die
+}
+
+src_compile() {
+ CHECK_DEPENDS=0 emake PYTHON="${EPYTHON}"
+}
+
+src_test() { :; } #324719
+
+src_install() {
+ DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" emake install
+ dodoc README
+
+ python_optimize "${ED}"/usr/$(get_libdir)/${PN}
+}
diff --git a/media-sound/listen/metadata.xml b/media-sound/listen/metadata.xml
new file mode 100644
index 000000000000..fbb7560bc15d
--- /dev/null
+++ b/media-sound/listen/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>
+ Listen, a music management and playback for GNOME
+
+ With listen you can
+
+ * Play your favorite songs
+ * Manage your library
+ * Manage your ipod
+ * Manage your podcast
+ * Make playlists
+ * Automatically or manually download album covers
+ * Automatically synchronize album covers with iPod
+ * Easily burn an audio CD
+ * Directly get informations from wikipedia when you play a song
+ * See the lyrics of a song
+ * Have statistics about your favorite songs, albums or artists
+ * Listen to web radio
+ * Submit your songs to Audioscrobbler
+ * Quick access to last.fm related file
+
+
+ With listen you will be able to
+
+ * Listen And Rip Audio CDs
+ * Browse and listen songs on a DAAP share
+ * Share you library via a DAAP share
+ * Fill metadata with musicbrainz
+ * Make inteligent playlists
+</longdescription>
+</pkgmetadata>