summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/glmix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/glmix')
-rw-r--r--media-sound/glmix/Manifest1
-rw-r--r--media-sound/glmix/glmix-0.3.ebuild35
-rw-r--r--media-sound/glmix/metadata.xml5
3 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/glmix/Manifest b/media-sound/glmix/Manifest
new file mode 100644
index 000000000000..ac8b5f9b4884
--- /dev/null
+++ b/media-sound/glmix/Manifest
@@ -0,0 +1 @@
+DIST glmix-0.3.tar.gz 17500 SHA256 901bbd5817e9a49426c2a143c09a251b83907e2a8f621ba231c19549e90884a8
diff --git a/media-sound/glmix/glmix-0.3.ebuild b/media-sound/glmix/glmix-0.3.ebuild
new file mode 100644
index 000000000000..6569c728b2af
--- /dev/null
+++ b/media-sound/glmix/glmix-0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A 3D widget for mixing up to eight JACK audio streams down to stereo"
+HOMEPAGE="http://devel.tlrmx.org/audio"
+SRC_URI="http://devel.tlrmx.org/audio/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND="media-sound/jack-audio-connection-kit
+ >=x11-libs/gtkglext-1
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ local libs="gtk+-2.0 gtkglext-1.0 jack pango"
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(pkg-config --cflags ${libs})" \
+ LDFLAGS="${LDFLAGS} $(pkg-config --libs ${libs})" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README TODO
+ make_desktop_entry ${PN} "GL Mixer"
+}
diff --git a/media-sound/glmix/metadata.xml b/media-sound/glmix/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/glmix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>