summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-03 23:20:25 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-03 23:20:56 +0200
commit6924f47fe17a0242f9fffeacf3b8b61cce748083 (patch)
tree47fe21497790567720c13cc7d811131622784cb1 /media-sound/adplay/adplay-1.7.ebuild
parentnet-nds/jxplorer: clean up old. (diff)
downloadgentoo-6924f47fe17a0242f9fffeacf3b8b61cce748083.tar.gz
gentoo-6924f47fe17a0242f9fffeacf3b8b61cce748083.tar.bz2
gentoo-6924f47fe17a0242f9fffeacf3b8b61cce748083.zip
media-sound/adplay: Allow for compiling with GCC 6
Gentoo-bug: 596092 Package-Manager: portage-2.3.1
Diffstat (limited to 'media-sound/adplay/adplay-1.7.ebuild')
-rw-r--r--media-sound/adplay/adplay-1.7.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/media-sound/adplay/adplay-1.7.ebuild b/media-sound/adplay/adplay-1.7.ebuild
index c84830cac6cc..6d5680f602af 100644
--- a/media-sound/adplay/adplay-1.7.ebuild
+++ b/media-sound/adplay/adplay-1.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
DESCRIPTION="A console player for AdLib music"
HOMEPAGE="http://adplug.sourceforge.net"
@@ -20,14 +20,13 @@ RDEPEND=">=media-libs/adplug-2.2.1
sdl? ( media-libs/libsdl )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=( "${FILESDIR}/${PN}-1.7-fix-c++14.patch" )
src_configure() {
econf \
+ --disable-output-esound \
$(use_enable alsa output-alsa) \
$(use_enable ao output-ao) \
- --disable-output-esound \
$(use_enable oss output-oss) \
$(use_enable sdl output-sdl)
}