summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-08-07 13:56:40 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-08-07 13:56:40 +0200
commitac9cabeb2f1a340f26ff3145e51d6dcd850ef45b (patch)
tree8970a794a78a4a1c780ee634e71b45bb12ea5ae7 /media-radio
parentwww-client/firefox: stabilize 115.14.0 for x86 (diff)
downloadgentoo-ac9cabeb2f1a340f26ff3145e51d6dcd850ef45b.tar.gz
gentoo-ac9cabeb2f1a340f26ff3145e51d6dcd850ef45b.tar.bz2
gentoo-ac9cabeb2f1a340f26ff3145e51d6dcd850ef45b.zip
media-radio/ax25-apps: Fix MUSL build problems
* switch from 'struct termio' to 'struct termios' * add some missing includes Closes: https://bugs.gentoo.org/715802 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/ax25-apps/ax25-apps-0.0.8_rc5-r1.ebuild5
-rw-r--r--media-radio/ax25-apps/files/ax25-apps-0.0.8-musl.patch52
2 files changed, 56 insertions, 1 deletions
diff --git a/media-radio/ax25-apps/ax25-apps-0.0.8_rc5-r1.ebuild b/media-radio/ax25-apps/ax25-apps-0.0.8_rc5-r1.ebuild
index b2cbb93ef638..c924ad277e18 100644
--- a/media-radio/ax25-apps/ax25-apps-0.0.8_rc5-r1.ebuild
+++ b/media-radio/ax25-apps/ax25-apps-0.0.8_rc5-r1.ebuild
@@ -23,7 +23,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="
- >=dev-libs/libax25-0.0.12_rc2:=
+ >=dev-libs/libax25-0.0.12_rc2
sys-libs/ncurses:=
!dev-ruby/listen
"
@@ -34,6 +34,9 @@ src_prepare() {
# fix missing prototype for malloc
sed -i -e "/^#include /i #include <stdlib.h>" ax25ipd/routing.c || die
eapply "${FILESDIR}"/${PN}-0.0.8_rc5-tinfo.patch
+ if use elibc_musl ; then
+ eapply -p1 "${FILESDIR}/${PN}-0.0.8-musl.patch"
+ fi
eapply_user
eautoreconf
}
diff --git a/media-radio/ax25-apps/files/ax25-apps-0.0.8-musl.patch b/media-radio/ax25-apps/files/ax25-apps-0.0.8-musl.patch
new file mode 100644
index 000000000000..3a83a73423e2
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25-apps-0.0.8-musl.patch
@@ -0,0 +1,52 @@
+*** a/ax25ipd/io.c 2019-03-20 17:48:59.000000000 +0100
+--- b/ax25ipd/io.c 2021-09-02 00:32:05.815175217 +0200
+***************
+*** 21,23 ****
+ #include <syslog.h>
+! #include <termio.h>
+ #include <time.h>
+--- 21,24 ----
+ #include <syslog.h>
+! #include <termios.h>
+! #include <sys/ioctl.h>
+ #include <time.h>
+***************
+*** 34,36 ****
+
+! static struct termio nterm;
+
+--- 35,37 ----
+
+! static struct termios nterm;
+
+*** a/call/call.h 2019-03-20 17:48:59.000000000 +0100
+--- b/call/call.h 2021-09-02 00:36:47.367157222 +0200
+***************
+*** 6,7 ****
+--- 6,13 ----
+ #endif
++
++ #ifndef __CALL_H
++ #define __CALL_H
++
++ #include <time.h>
++
+ extern int fd;
+*************** extern int yapp2unix(char *);
+*** 21 ****
+--- 27,29 ----
+ extern void unix2yapp(time_t unix_date, char *buffer);
++
++ #endif
+diff --git a/ax25rtd/ax25rtd.c b/ax25rtd/ax25rtd.c
+index d4c8b58..ea1ef86 100644
+--- a/ax25rtd/ax25rtd.c
++++ b/ax25rtd/ax25rtd.c
+@@ -33,6 +33,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <errno.h>