summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-14 15:14:54 -0400
committerSam James <sam@gentoo.org>2024-03-14 19:20:47 +0000
commit7540cd2f4031823c381091e2bfe85222bdfe7686 (patch)
treeff7ac930b2ed468228600e7ead6fc6fa9f216fd1 /media-radio
parentmedia-libs/hamlib: mark as LTO-unsafe (diff)
downloadgentoo-7540cd2f4031823c381091e2bfe85222bdfe7686.tar.gz
gentoo-7540cd2f4031823c381091e2bfe85222bdfe7686.tar.bz2
gentoo-7540cd2f4031823c381091e2bfe85222bdfe7686.zip
media-radio/js8call: mark as LTO-unsafe
The issue tracker uses bitbucket, and the project hasn't seen activity since 2020. With some effort and frustration I could interact with JIRA to report the issue but it feels very unrewarding to do so if I don't expect a response. Sorry, JIRA lovers. Closes: https://bugs.gentoo.org/860411 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/js8call/js8call-2.2.0-r1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-radio/js8call/js8call-2.2.0-r1.ebuild b/media-radio/js8call/js8call-2.2.0-r1.ebuild
index 08a55170fb78..027d99bc6d41 100644
--- a/media-radio/js8call/js8call-2.2.0-r1.ebuild
+++ b/media-radio/js8call/js8call-2.2.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake vcs-snapshot
+inherit cmake flag-o-matic vcs-snapshot
MY_P=${P/_/-}
@@ -32,6 +32,16 @@ RDEPEND="dev-qt/qtcore:5
doc? ( dev-ruby/asciidoctor )"
DEPEND="${RDEPEND}"
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/860411
+ #
+ # Upstream is on bitbucket, no activity since 2020.
+ filter-lto
+
+ cmake_src_configure
+}
+
src_install() {
cmake_src_install
rm "${D}"/usr/bin/rigctl{,d}-local || die