summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-imonlcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-imonlcd')
-rw-r--r--media-plugins/vdr-imonlcd/Manifest2
-rw-r--r--media-plugins/vdr-imonlcd/files/99-imonlcd.rules1
-rw-r--r--media-plugins/vdr-imonlcd/files/confd8
-rw-r--r--media-plugins/vdr-imonlcd/files/rc-addon.sh6
-rw-r--r--media-plugins/vdr-imonlcd/metadata.xml5
-rw-r--r--media-plugins/vdr-imonlcd/vdr-imonlcd-0.0.5-r1.ebuild43
-rw-r--r--media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.1.ebuild37
7 files changed, 102 insertions, 0 deletions
diff --git a/media-plugins/vdr-imonlcd/Manifest b/media-plugins/vdr-imonlcd/Manifest
new file mode 100644
index 000000000000..ccee9af76e0e
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/Manifest
@@ -0,0 +1,2 @@
+DIST vdr-imonlcd-0.0.5.tgz 43380 SHA256 1c786f5c0e8cd8039477d4a54e053905414ddc6424ecc573446b2420bdbbdaed SHA512 89082591c953d8f5883efc1d6e65d8c5fa54087b8baaff70b2de264323086cc76b33d9aa16e0bbe39c4f23ce94f5f1c31649c286b2034ea0d91fe8d8aa26edd6 WHIRLPOOL d440cb3a1da8e32b29e174402b01a42dd5b04896e60b6a0bb112417998160579c525b87c37fedcba88a5b338ad895293ad3bb9d84861a3a92091d7ed6f74d1da
+DIST vdr-imonlcd-1.0.1.tgz 44423 SHA256 b05f10eae78099eafab1a5f0eac6d1474b55d294ae898f76a09e2e45e919c8d6 SHA512 5912a51d01eab45c7a71cf9939e3947bde69ebbe413aefd5601734b60fb853bff6b2ae7a4c3e68aba7f5bd75b33921fec664d66128942ce0f223d4a2bbe53512 WHIRLPOOL 80014b749dae8e5c9f0bd4c9286d665cbd114adf1a4b32f0a74d895cf0b354eee745374e7747d31e48ce8a1a4c8ff34b919b2eb81f55e9ae1a23c17596bb825f
diff --git a/media-plugins/vdr-imonlcd/files/99-imonlcd.rules b/media-plugins/vdr-imonlcd/files/99-imonlcd.rules
new file mode 100644
index 000000000000..e65bab742773
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/files/99-imonlcd.rules
@@ -0,0 +1 @@
+ACTION=="add", KERNEL=="lcd*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="15c2", ATTRS{idProduct}=="*", MODE="0660", GROUP="video"
diff --git a/media-plugins/vdr-imonlcd/files/confd b/media-plugins/vdr-imonlcd/files/confd
new file mode 100644
index 000000000000..6bfd930235fa
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/files/confd
@@ -0,0 +1,8 @@
+# $Id$
+
+#IMONLCD_DEVICE=/dev/lcd0
+
+# Protocol of lcd-device (see lsusb)
+# 0038 - For LCD with ID 15c2:0038 SoundGraph Inc (default)
+# ffdc - For LCD with ID 15c2:ffdc SoundGraph Inc
+#IMONLCD_PROTOCOL=0038
diff --git a/media-plugins/vdr-imonlcd/files/rc-addon.sh b/media-plugins/vdr-imonlcd/files/rc-addon.sh
new file mode 100644
index 000000000000..2857bd284aa3
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/files/rc-addon.sh
@@ -0,0 +1,6 @@
+# $Id$
+
+plugin_pre_vdr_start() {
+ add_plugin_param "${IMONLCD_DEVICE:+--device ${IMONLCD_DEVICE}}"
+ add_plugin_param "${IMONLCD_PROTOCOL:+--protocol ${IMONLCD_PROTOCOL}}"
+}
diff --git a/media-plugins/vdr-imonlcd/metadata.xml b/media-plugins/vdr-imonlcd/metadata.xml
new file mode 100644
index 000000000000..53d38987c8c0
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+</pkgmetadata>
diff --git a/media-plugins/vdr-imonlcd/vdr-imonlcd-0.0.5-r1.ebuild b/media-plugins/vdr-imonlcd/vdr-imonlcd-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..68cd2156984e
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/vdr-imonlcd-0.0.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info vdr-plugin-2 udev
+
+DESCRIPTION="VDR Plugin: shows information about the current state of VDR on iMON LCD"
+HOMEPAGE="http://projects.vdr-developer.org/wiki/plg-imonlcd"
+SRC_URI="mirror://vdr-developerorg/408/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/freetype"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="~IR_IMON"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ vdr-plugin-2_pkg_setup
+}
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if ! use nls; then
+ sed -i -e 's/\(all: libvdr-$(PLUGIN).so\) i18n/\1/' Makefile || die
+ fi
+}
+
+src_install() {
+ rm -f README.git
+ vdr-plugin-2_src_install
+
+ insinto $(get_udevdir)/rules.d
+ doins "${FILESDIR}"/99-imonlcd.rules || die
+}
diff --git a/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.1.ebuild b/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.1.ebuild
new file mode 100644
index 000000000000..7c233a503181
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2 linux-info udev
+
+VERSION="1327" # every bump, new version
+
+DESCRIPTION="VDR Plugin: shows information about the current state of VDR on iMON LCD"
+HOMEPAGE="http://projects.vdr-developer.org/wiki/plg-imonlcd"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freetype"
+DEPEND="${RDEPEND}
+ media-video/vdr"
+
+CONFIG_CHECK="~IR_IMON"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ vdr-plugin-2_pkg_setup
+}
+
+src_install() {
+ rm -f README.git
+ vdr-plugin-2_src_install
+
+ insinto $(get_udevdir)/rules.d
+ doins "${FILESDIR}"/99-imonlcd.rules || die
+}