summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-30 13:39:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-30 13:51:02 +0200
commit41994240d5a6caae4fd9dfff2b7ed6c40eff46fd (patch)
tree590fb50d781e0061b81d83441d423e972844ba55 /media-plugins/vdr-fritzbox
parentmedia-libs/mlt: Add ruby25 support (diff)
downloadgentoo-41994240d5a6caae4fd9dfff2b7ed6c40eff46fd.tar.gz
gentoo-41994240d5a6caae4fd9dfff2b7ed6c40eff46fd.tar.bz2
gentoo-41994240d5a6caae4fd9dfff2b7ed6c40eff46fd.zip
media-plugins/vdr-fritzbox: Fix build with >=boost-1.67
Non-maintainer commit after timeout. Closes: https://bugs.gentoo.org/671468 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-fritzbox')
-rw-r--r--media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch22
-rw-r--r--media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild34
2 files changed, 56 insertions, 0 deletions
diff --git a/media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch b/media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch
new file mode 100644
index 000000000000..f57338782795
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/files/vdr-fritzbox-1.5.3-boost-1.67.patch
@@ -0,0 +1,22 @@
+From 212847f0efaeffee8422059b8e202d844174aaf3 Mon Sep 17 00:00:00 2001
+From: Joachim Wilke <github.com@joachim-wilke.de>
+Date: Thu, 28 Jun 2018 12:56:54 +0200
+Subject: [PATCH] Add compatibility with boost 1.67
+
+Refers to https://github.com/jowi24/vdr-fritz/issues/1
+---
+ TcpClient.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/TcpClient.cpp b/TcpClient.cpp
+index b9b38e9..c6cc08e 100644
+--- a/libnet++/TcpClient.cpp
++++ b/libnet++/TcpClient.cpp
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#define BOOST_ASIO_USE_BOOST_DATE_TIME_FOR_SOCKET_IOSTREAM
+ #include "TcpClient.h"
+
+ #include <liblog++/Log.h>
diff --git a/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..eaa4abe5e236
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Inform about incoming phone-calls and use the fritz!box phonebook"
+HOMEPAGE="https://github.com/jowi24/vdr-fritz"
+SRC_URI="https://github.com/jowi24/vdr-fritz/releases/download/1.5.3/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0
+ dev-libs/boost[threads]
+ >=media-video/vdr-1.7.34
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.67.patch" )
+
+pkg_postinst() {
+ elog "It is recommend to update your firmware release to the latest."
+ elog
+ elog "The integrated call monitor (available in Fritz!Box official"
+ elog "firmware releases >= *.04.29) has to be enabled in order to"
+ elog "have the vdr-fritzbox plugin display anything on your tv. To"
+ elog "enable it call #96*5* from your telephone. If that doesn't"
+ elog "work for you, read the documentation for further instructions."
+}